WordPress.org

Ready to get started?Download WordPress

Plugin Directory

WP YouTube Lyte

High performance YouTube video, playlist and audio-only embeds which don't slow down your blog and offer optimal accessibility.

WP YouTube Lyte allows you to "lazy load" your video's, by inserting responsive "Lite YouTube Embeds". These look and feel like normal embedded YouTube, but only call the actual "fat" Flash or HTML5-player when clicked on, thereby reducing download size & rendering time substantially when embedding YouTube occasionally and improving page performance dramatically when you've got multiple YouTube video's on one and the same page.

Just add a YouTube-link for a video or an entire playlist with "httpv" (or "httpa" to embed YouTube's audio only) instead of "http" or add a Lyte widget to your sidebar and WP YouTube Lyte replaces that link with the correct performance-optimized code. When a visitor clicks the play-button, WP YouTube Lyte seamlessly initiates YouTube's new embedded player. Some examples:

  • httpv://www.youtube.com/watch?v=_SQkWbRublY (normal video embed)
  • httpv://youtu.be/_SQkWbRublY (video embed with youtube-shortlink)
  • httpa://www.youtube.com/watch?v=_SQkWbRublY (audio only embed)
  • httpv://www.youtube.com/playlist?list=PLA486E741B25F8E00 (playlist embed)
  • httpv://www.youtube.com/watch?v=_SQkWbRublY#stepSize=-1 (video player, one size smaller than what's configured as default)
  • httpv://www.youtube.com/watch?v=_SQkWbRublY?start=20&showinfo=0 (video player, start playing at 20 seconds and don't show title)

Or using shortcodes:

[lyte id="_SQkWbRublY" /]
[lyte id="_SQkWbRublY" audio="true" /]
[lyte id="A486E741B25F8E00" playlist="true" /]

WP YouTube Lyte has been written with optimal performance as primary goal, but has been tested for maximum browser-compatibility (iPad included) while keeping an eye on accessibility. Starting with version 1.2.0 lyte embeds are fully responsive and can automatically embed videoObject microdata as well. The plugin is fully multi-language, with support for Catalan, Dutch, English, French, German, Hebrew, Romanian, Spanish and Slovene.

Feedback is welcome; see info in the faq for bug reports/ feature requests and feel free to rate and/or report on compatibility on wordpress.org.

Requires: 2.9 or higher
Compatible up to: 3.9
Last Updated: 2014-4-18
Downloads: 190,551

Ratings

4 stars
4.6 out of 5 stars

Support

6 of 7 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,1,1 100,2,2 50,2,1 100,1,1
100,1,1
100,1,1 100,1,1 100,1,1
100,1,1 100,3,3
100,1,1 100,1,1
0,1,0 100,2,2 100,5,5
100,3,3 100,1,1 100,1,1 100,2,2
100,1,1
100,2,2
100,1,1 100,1,1 50,2,1 100,1,1 100,1,1 100,3,3 100,2,2 100,1,1 0,1,0 0,1,0
100,1,1 100,3,3 100,1,1
100,2,2 100,2,2 100,3,3 100,3,3 100,2,2 100,1,1
80,5,4 67,3,2 100,1,1
50,2,1
75,4,3 0,1,0 75,4,3
100,3,3 100,1,1 100,3,3
100,1,1
100,1,1 100,2,2 100,3,3 100,2,2
100,1,1 100,1,1
100,1,1 100,1,1 100,1,1
100,1,1 100,1,1
100,1,1
100,1,1 67,3,2
100,1,1
100,1,1
100,1,1