WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

WP SyntaxHighlighter

This plugin is code syntax highlighter based on SyntaxHighlighter ver. 3.0.83 and 2.1.382.

This plugin is code syntax highlighter based on Alex Gorbatchev's SyntaxHighlighter ver. 3.0.83 and 2.1.382.

Features

  • Based on Alex Gorbatchev's "SyntaxHighlighter" JavaScript library.
  • Including both SyntaxHighlighter 3.0.83 and 2.1.382.(Can switch between 3.0.83 and 2.1.382.)
  • Built-in TinyMCE buttons and Quicktag button are easy to operate.
  • Easy to wrap your code in <pre> tag and change options of previously-wrapped code.
  • Support shortcode also.
  • Easy to highlight code in comments using buttons.(WordPress 3.0 or higher)
  • Widget to show highlighted code.
  • Support bbPress plugin 2.0 or higher.
  • Support "Dynamic Brush Loading" which allows to load only necessary brush files dynamically.
  • Loading JavaScripts on only posts, pages, home, archives, search results and comments which have the code to highlight.
  • Easy to configure features through the setting panel.
  • Localization: English(Default), 日本語(Japanese, UTF-8).

Supported languages

AppleScript, ActionScript3, Bash, ColdFusion, C, C++, C#, CSS, Delphi, Diff, Erlang, Groovy, HTML, Java, Java FX, JavaScript, Pascal, Patch, Perl, PHP, Plain text, PowerShell, Python, Ruby, Ruby on Rails, Sass, SCSS, Shell, SQL, VB, VB NET, XHTML, XML and XSLT

Note: A part of languages are only for SyntaxHighlighter 3.0.

You can also use a bundled plugin to add following languages.

Biferno, Clojure, DOS batch file, F#, LISP, Lua(only for SyntaxHighlighter 3.0), MEL Script, Objective-C, PowerCLI, Processing, R, S, S-PLUS, Tcl, Verilog, Vim Script and YAML

For details, see "sample" directory.

There are many other languages for "SyntaxHighlighter". But I can't bundle them because they are not compatible with this plugin license. If you want, try to search.

Recommended plugin

Thanks

Requires: 2.8 or higher
Compatible up to: 3.3.2
Last Updated: 2012-2-29
Downloads: 42,276

Ratings

4 stars
4.9 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,2,2 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1
100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,2,2 100,2,2 100,3,3 100,1,1 100,4,4 100,1,1 100,1,1 100,1,1 100,1,1
100,1,1 100,2,2
100,1,1 100,2,2 100,1,1 100,4,4
100,2,2
100,1,1
83,6,5
100,1,1
100,1,1
100,2,2
100,1,1