WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

WP-Spellcheck

TinyMCE SpellChecker API - this plugin provides action/filter hooks to allow easy customisation of the TinyMCE SpellChecker.

TinyMCE SpellChecker API - this plugin provides action/filter hooks to allow easy customisation of the TinyMCE SpellChecker.

This plugin was created to solve the problem of not being able to use GoogleSpell behind a firewall. For background information on the issue read the discussions on trac ticket #9798. The ultimate goal of this plugin is to be merged into WordPress Core.

You need this plugin if...

  • You want to write a plugin for the TinyMCE SpellChecker. This plugin will provide you with respective hooks that allow to control which SpellChecker Engine is used, adjust the configuration used for initialisation of the engine and manipulate spellchecking results (independent of engine).
  • You are behind a firewall and you'd like to use the Google Spellchecker. This plugin contains a customised version of GoogleSpell that uses the new Http Transportation methods added in WordPress 2.8 which include Proxy Support for all external requests.

This plugin also contains a simple sub-plugin called "WP-SpellCheck Exceptions" which allows you to add custom words to the spellchecking dictionary. Note that this plugin is more a proof of concept than a complete/full-fleged solution. (It does not have any kind of visual administration; it only adds "WordPress" as an exception at the moment).

Requires: 2.8 or higher
Compatible up to: 2.8
Last Updated: 2009-5-29
Downloads: 1,116

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1