WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

WP Google Plus Connect

Add Google+ Direct Connect Badge & allow your WordPress/BuddyPress users to register or login via their Google+ account & import their stream

Display a Google+ Direct Connect Badge on your site via widget or shortcode, allow your members to login/register via their Google+ account or sync your Google+ stream with your blog posts or BuddyPress activity via the Google+ API.

WordPress Google+ Connect allow your website members the ability to register and/or log in via their Google+ account utilizing the Google+ API. Set up a Google Plus Application and store the API credentials in the WordPress backend, when a user clicks on the "Login with Google+" button that gets added to the WP log in screen or anywhere via a short code and authenticates their Google Plus account a WordPress account will be created with their G+ information and they will automatically be logged in. Any existing WordPress users can also log in via Google+ and link their two accounts.

If BuddyPress is enabled a Google+ login button will appear on the sidebar login and the registration page. Google+ profile photos will also be imported in as BuddyPress avatars. Members can stream their Google+ activity into their BuddyPress activity if they choose via the Google+ options screen under the logged in BuddyPress members profile settings page. A cron job runs every 30 minutes to import any new Google plus activity from connected users.

Configure Google+ Direct Connect and help visitors find your Google+ page and add it to their circles from directly within a Google Search.

Configure your Google+ Badge and allow visitors to directly connect with and promote your brand on Google+. Visitors can also add your Google+ page to their circles directly from your website. Badges are easy to configure and can be placed on your website via a short code or a widget.

Requires: 3.0 or higher
Compatible up to: 3.3.2
Last Updated: 2011-11-19
Downloads: 13,313

Ratings

3 stars
3.4 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2 100,1,1 33,3,1 100,1,1 17,6,1
0,2,0 0,4,0
10,10,1
0,3,0
0,1,0
0,1,0