WordPress.org

Ready to get started?Download WordPress

Plugin Directory

WPF-jqGrid

Use jqGrid (a jQuery plugin) to manage database tables. Use shortcode like [wpf-jqgrid table='wpf_jqgrid_sample' idtable=1 caption='nam

Is it free?

Yes! The plugin is free. And jqGrid is free too, refers to: http://www.trirand.com/blog/?page_id=932

The plugin is not working! What can I do?

Please send me the description of the error, and all the info you can about your configuration (WP, PHP and MySQL versions, configuration details,...). Useful may be also the MySQL script to create your table and the malfunctioning page html code. You can use WP plugin support page. I'll be happy to help you!

What I should be aware of?

  • Remember to set 'Enable' in the configuration page.
  • Remember to list your table in the allowed ones in configuration page.
  • The 'custom fields formatting' is very tricky: use it only if you know what you are doing!
  • The 'idtable' must be unique for each grid displayed: you can even display the same db table multiple times, but with differnet idtables.
  • Some themes may require a css tuning to display properly all the elements.

Which are the know limitations or issues?

  • There is a column order issue with Theme Twenty Fourteen that I was unable to fix (if you can, please let me know!). Please use a different Theme.
  • Your table MUST have ONE and ONLY ONE field set as primary key, if not the first field will be use as PK.
  • The fields render and size are set to a default, possible but not easy to set them for each field
  • No decode/pull down lists available
  • No master/detail feature
  • Must insert numbers with DOT decimal separator and NO thousand separator
  • Datetime edit check is not supported in jqGrid
  • (all these will be fixed in future releases, but until now...)

Third parts js and css

TODO

  • set rights to modify tables on setup and check on frontend
  • set key field(s) on fronted or from DB
  • decode required fields with a scrolldown list
  • edit/delete/insert on line
  • 1 to n slave table
  • simplify formatting settings on frontend for each field of a selected table

Requires: 3.5 or higher
Compatible up to: 4.0
Last Updated: 2014-8-14
Downloads: 836

Ratings

5 stars
5 out of 5 stars

Support

2 of 4 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1