WordPress.org

Ready to get started?Download WordPress

Plugin Directory

WP DB Driver

An improved database layer for WordPress

1.8.1 (2014-08-08)

  • Fix setting charset and SQL mode for PDO

1.8 (2014-08-07)

  • Synced with trunk to Changeset 29165 excluding 27075
    • Ensure compatibility with MySQL 5.6 which has stricter SQL modes by default
    • Throw an incorrect usage notice when the query argument of wpdb::prepare() does not include a placeholder.
    • When the MySQL server has "gone away," attempt to reconnect and retry the query.
  • Don't extend wpdb anymore to be on the safe side
  • Works with socket connections
  • More abstraction from the main db class to our interface.
  • Added a banner image for WordPress.org. Thanks to Marcel van der Horst

1.7 (2014-01-30)

  • Synced with trunk to Changeset 25703
  • Works when plugins folder has been changed
  • Added network support
  • Security enhanchement when using a network installation
  • Updated readme

1.6 (2013-09-18)

  • Fix returning incorrect number of rows for some queries. Props markmont
  • Add error_handler
  • Trowing doing_it_wrong message for all mysql_* functions

1.5 (2013-08-04)

  • Fix dbDelta() to create tables when the tables do not exists
  • Fix fatal error when database can't get selected by PDO
  • Fix notices when using MySQLi query() when $this->result isn't an object
  • When database can't get selected show the default message instead of installation screen

1.4 (2013-08-02)

  • Fix notices due changes in WordPress 3.6.
  • Add SSL support. Props hypertextranch.

1.3 (2013-07-09)

  • Show install button when db.php is different.
  • Don't show remove button when mysql extension isn't installed.
  • Compatibility fixes for unit tests.

1.2 (2013-06-30)

  • Added emergency override.
  • Updated readme.

1.1 ( 2013-06-28 )

  • Fixes for MySQLi driver, PDO driver.
  • Uses WP_Filesystem for writing / removing db.php when possible.
  • Added deactivate / uninstall code.

1.0 ( 2013-06-28 )

  • First version that supports PDO and MySQLi. Props kurtpayne and scribu.

Requires: 3.6 or higher
Compatible up to: 4.0
Last Updated: 2014-8-8
Downloads: 1,665

Ratings

5 stars
5 out of 5 stars

Support

1 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,1,1
100,1,1