WordPress.org

Ready to get started?Download WordPress

Plugin Directory

WP DB Driver

The possible new database layer for WordPress core

The mysql_* functions are officially deprecated for PHP 5.5 and are throwing E_DEPRECATED errors. On http://core.trac.wordpress.org/ticket/21663 there is discussion on this topic.

This plugin reflects those discussions.

Why should I use this plugin?

You should use this plugin if you want to help test the proposed changes for PDO / MySQLi for WordPress. Or if you need PDO / MySQLi support for some reason (e.g. you're running php 5.5, your server doesn't have classic mysql bindings, etc.)

This plugin is still in development.

Requires: 3.6 or higher
Compatible up to: 3.8.3
Last Updated: 2014-1-30
Downloads: 1,474

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,1,1
100,1,1