WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

WP Category Post List Widget

Widget & Shortcode to list down posts filtered by Category, with Thumbnails, Custom HTML structure, Excerpt, CSS theme with API & much more

Version 2.0.3

  • Bug fix: On wp_cpl_output_gen.php file
  • Added: Current Post category is now current post/archive page category. So a category archive page will populate the widget.

Version 2.0.2

  • Bug fix to the occasion when no theme is selected
  • Added a Reset button to reset all the options in case of corruption

Version 2.0.1

  • Immediate bug fix to the WordPress auto-update.

Version 2.0.0

  • Ability to select the category of the current post (Auto category detection)
  • Shortcode support
  • Post excerpt and other options like html enabled Readmore and subscription.
  • Different height and width for widget and shortcode thumbnail
  • Display author, date and other post meta.
  • Added filter API to use your own CSS Theme with the plugin (both for widget and shortcode)

Version 1.1.0

  • Not released in the WILD
  • Ability to select the category of the current post
  • Shortcode support (proposed)
  • Minor bug fixes
  • Options to show post date, author and excerpt
  • New interface for read more and feed link

Version 1.0.0

  • Public Release
  • Several bugs fixed
  • Fixed the Read More permalink bug
  • Added 2 more themes
  • Added Teaser Option

Version 0.9.0 RC

  • Themeing Support
  • Complete Widget Interface
  • Stand alone support for WordPress post thumbnail activation. Even if your theme does not support.
  • All Documentation can be found in the Plugins Settings page

Version 0.0.9 alpha

  • Added basic widget querying of posts
  • Added thumbnail support etc.
  • Still under development. Please dont install

Version 0.0.8 alpha

  • Initial Upload to WP SVN
  • Under development. Please dont't install

Requires: 3.0 or higher
Compatible up to: 3.4.2
Last Updated: 2012-5-16
Downloads: 94,042

Ratings

4 stars
4.8 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,5,5
100,1,1
100,3,3
100,1,1
100,3,3
100,5,5
100,2,2
100,1,1 100,1,1 75,8,6
50,4,2 100,2,2
100,2,2
80,5,4
100,2,2
100,3,3
75,4,3
100,1,1
100,2,2
50,2,1
100,1,1
100,1,1