WordPress.org

Ready to get started?Download WordPress

Plugin Directory

WP Approve User

Adds action links to user table to approve or unapprove user registrations.

2.3

  • Added French translation. Props Clovis Darrigan.
  • Added Arabic translation. Props Mehdi Bounya.

2.2.3

  • Fixes a bug where administrators where locked out of their site if user registration was enabled after the plugin was.

2.2.2

  • Adds backwards compatibility for WordPress versions pre-3.5 for the user list filter.
  • Removes unused development versions of scripts and styles.

2.2.1

  • Updated utility class.

2.2.0

  • Added a way to filter for unapproved users in the admin user list.
  • Fixed a bug where currently active users would not be flagged as approved on activation if user registration was disabled.
  • Added Dutch translation. Props Jos Wolbers.
  • Minor coding convention updates to be closer to core coding guidelines.
  • Tested with the beta version of 3.6.

2.1.1

  • Fixed a bug, where new settings were not saved.

2.1.0

  • Added Russian translation. Props Mick Levin.
  • Email bodies can now be edited even when email notification is not activated.
  • Fixed a bug, where admin notices by the Settings API were not displayed.

2.0.0

  • Added the ability to send an email on approval/unapproval. Email text can be customized.
  • Optimized alteration of Users menu item. Props Rd.
  • Added Hebrew translation. Props asafche.

1.1.1

  • Fixed a bug, where the call to action bubble didn't account for newly registered.

1.1.0

  • Added bulk action for approving and unapproving users.
  • Added notification of unapproved users in admin menu item (WordPress 3.2+).
  • Added highlight of unapproved users.
  • Added action hooks on (un-)approval. See hook reference.
  • Users created by an Administrator will automatically be approved.
  • Updated utilities class.
  • Now an instance of the Obenland_Wp_Approve_User object ist stored in a static property to make deregistration of hooks easier.

1.0

  • Initial Release.

Requires: 3.1 or higher
Compatible up to: 3.6.1
Last Updated: 2013-12-24
Downloads: 15,715

Ratings

4 stars
4.6 out of 5 stars

Support

1 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1 100,3,3
100,2,2 100,3,3
100,1,1
100,1,1 100,1,1 67,3,2
100,2,2
100,1,1
100,1,1
100,1,1
100,2,2