WordPress.org

Ready to get started?Download WordPress

Plugin Directory

WordPress Password Expiry

Expires password for the selected type of users on the site after every specified number of days.

1.5

  • Added new features :
  • Show 'Reset' link to reset password
  • Show 'Request' link for getting request for resetting password
  • Show custom message instead of reset/request links
  • Added plugin support sidebar.
  • Added external CSS files and moved all major styling into it. Some new styling also added.
  • Added some jQuery effects for newly added features.
  • Tested compatability with WordPress 3.5.1

1.4

  • Resolved conflict with 'WordPress iOS app'.
  • Tested compatability with WordPress 3.5

1.3.5

  • Changed 'expire()' function name to a unique name to avoid a conflict.

1.3

  • Developed feature for expiring password for users with custom roles.
  • Fixed a bug - 'Notice: Constant WPINC already defined in /home/user/domains/domain/public_html/wp-content/plugins/wordpresspasswordexpiry/pwd-exp.php on line 31 '
  • Tested compatibility with WordPress latest version(3.4.2).

1.2

  • Provided list of site users types including administrators.
  • Developed option to select any types of users for setting password expiration time and message for them.
  • A special feature(managing option for their own) for 'Main Adminstrator'.
  • Tested compatibility with WordPress latest version(3.4.1).

1.1

  • Fixed a bug: In previous version, by default, only the main admin's password would never expire. Other administrative user's password would expire. Now, no administrative user's password expire by default. Only non admin user's password expire by default. So, if other administrative users install this plugin, he/she will be safe from expiration.
  • Changed layout of this plugin's settings page.
  • Tested compatibility with WordPress latest version(3.4).

1.0

  • First version.

Requires: 3.3.1 or higher
Compatible up to: 3.5.2
Last Updated: 2013-3-1
Downloads: 3,936

Ratings

5 stars
5 out of 5 stars

Support

0 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2
100,1,1 100,1,1
100,1,1
100,1,1 100,1,1