WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

WordPress Forms

Create your Web forms quickly and intuitively, and use them within your Posts, Pages or even published in a single location.

IMPORTANT NOTE: This is a Beta version of this plugin. You should NOT use it in production instances. Future releases will demand stable releases. Stay in touch!

One of the barriers that users of WordPress have to face is the creation of custom Web forms. Many plugins exist but they are always either too difficult for the end-user or too inflexible. This plugin redesigns this concept: a fast and intuitive creation of both basic or professional custom forms that are effective and only requires from the user a mouse and their imagination!

With the power of the newly created Custom Post Types You Will Be Able to:

  • Quickly create forms with a single click by selecting the elements you want.
  • Modify the advanced options for each field.
  • Specify an email which will be sent the submissions to the forms or
  • Specify an external location in order to process the submitted data.
  • Embed forms into Posts and Pages with through a button in the WYIWYG Editor or simply ...
  • Publish the forms in a single location as if it were a page or a post.

  • A super-clean interface that does not exclude anyone!

We are committed with the interface's simplicity and flexibility for the end-user.

More features will come in a future release.

Technology The forms are already prepared to be processed in AJAX with the help of jQuery which also performs a validation to the inputs of each field.

If you're a developer

  • We want to make this plugin as simple and intuitive, robust and flexible as possible.
  • Our goal it to make it an usefull plugin that community can be proud of.
  • We want to offer this to the community WordPress: Help us!

Requires: 3.0 or higher
Compatible up to: 3.0.5
Last Updated: 2010-11-7
Downloads: 20,351

Ratings

3 stars
3.9 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1 0,1,0 100,1,1 100,1,1 100,1,1 100,1,1 80,5,4 57,7,4
100,2,2 100,1,1
67,3,2 100,1,1 100,1,1
100,2,2
100,1,1
67,6,4
0,2,0
100,2,2
0,3,0
0,1,0