WordPress.org

Ready to get started?Download WordPress

Plugin Directory

WooCommerce MailChimp

Simple and flexible MailChimp integration for WooCommerce.

1.3.1

  • Fix for MailChimp merge vars bug introduced in v1.3

1.3

  • Breaking Change: 'ss_wc_mailchimp_subscribe_merge_vars' action filter now passes $order_id param to enable retrieving additional order info/meta to use in MailChimp merge vars
  • Small fix to order_created subscribe event to work with PayPal Payment Gateway

1.2.6

  • Added additional debug logging when WP_DEBUG is enabled

1.2.5

  • Bug fix for subscribe when not using opt-in display field

1.2.4

  • Bug fix for subscribe

1.2.3

  • Fixed plugin settings link for WooCommerce 2.1

1.2.2

  • WooCommerce 2.1 fix for order custom fields

1.2.1

  • WooCommerce 2.1 integration: Change to use wc_enqueue_js instead of add_inline_js
  • WooCommerce 2.1 integration: Change to support new default checkout field filter for default opt-in checkbox status

1.2

  • Added new setting to control whether or not the double opt-in checkbox is checked/unchecked by default on the checkout page.
  • Added new setting to control display location of the double opt-in checkbox (under billing info or order info)
  • Small modification to append to MailChimp interest groups for existing users so that group settings are not lost for users who were already subscribed.
  • Preparations for i18n (Internationalization) support. Several users have already asked and offered to translate the plugin into other languages. We had always planned on that, but now are making that a reality.

1.1.3

  • Minor action hook change since order meta (needed for MailChimp API call) is not yet available on 'woocommerce_new_order' hook

1.1.2

  • Update to REALLY address issue with subscriptions not occurring on order create "pending"

1.1.1

  • Update to address issue with subscriptions not occurring on order create "pending"

1.1

  • Add the option to display an opt-in field on checkout

1.0.2

  • Minor text and comment changes

1.0.1

  • Added "Settings" link on the Plugins administration screen

1.0

  • This is the first public release.

Requires: 3.5.1 or higher
Compatible up to: 3.8.3
Last Updated: 2014-4-3
Downloads: 17,322

Ratings

4 stars
4.5 out of 5 stars

Support

0 of 4 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,2,2
100,1,1 0,1,0 100,1,1 100,1,1 0,1,0 100,1,1
100,1,1