WordPress.org

Ready to get started?Download WordPress

Plugin Directory

WooCommerce Coupon Shortcodes

Show coupon discount info using shortcodes. Allows to render coupon information and content conditionally, based on the validity of coupons.

This extension for WooCommerce allows you to render coupon information and show content based on the validity of coupons.

Customers can be motivated to proceed with their purchase, offering them to use specific coupons when the contents in the cart qualify for it, or by offering them to purchase additional items so they can use a coupon.

Extended coupon discount info for volume discounts is shown automatically, if the WooCommerce Volume Discount Coupons is installed.

Conditional Shortcodes

It provides the following conditional shortcodes that allow to enclose content which is shown if coupons are applied, valid or not valid.

[coupon_is_applied]
[coupon_is_valid]
[coupon_is_not_valid]

Coupon Info Shortcodes

It also provides shortcodes that allow to render the coupon code, its description and an automatic description of the discount:

[coupon_code]

(this one makes sense mostly when used inside one of the conditional shortcodes).

[coupon_description]
[coupon_discount]

A coupon enumerator shortcode allows to list all or a set of coupons, to show their code, description or discount information:

[coupon_enumerate]

Documentation

Please refer to the plugin's documentation pages for detailed descriptions.

Examples

Showing a coupon when the cart contents qualify for a coupon to be applied:

[coupon_is_valid code="superdiscount"]
You qualify for a discount!
Use the coupon code [coupon_code] to take advantage of this great discount : [coupon_discount]
[/coupon_is_valid]

Showing a coupon that is not valid for the current cart and motivating to add items:

[coupon_is_not_valid code="25off"]
If you purchase 5 Widgets, you can use the coupon [coupon_code] to get 25% off your purchase!
[/coupon_is_not_valid]

Documentation and Support

Full usage instructions and help is provided on these pages:

Requires: 3.3 or higher
Compatible up to: 3.9.1
Last Updated: 2014-5-4
Downloads: 3,393

Ratings

5 stars
5 out of 5 stars

Support

0 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1