WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

VSF Simple Block

VSF Simple Block plugin. Acts as a sort of software firewall.

I'm getting an error during export / import

Go to the plugin website and post a comment on the simple block page with as much information as possible please.

How do I block a single IP address, E.g. 192.168.0.1?

Go to Settings -> VSF Simple Block. Select Block Rules. In the block rules page make sure "IP Address" is selected in the drop down. In the text box labeled "Value" enter the IP address you wish to block and a description if wanted and then click the "Add new Block User Rule" button.

How do I block an IP range, E.g. 192.168.0.1 through to 192.168.0.12?

Go to Settings -> VSF Simple Block. Select Block Rules. In the block rules page make sure "IP Address" is selected in the drop down. In the text box labeled "Value" enter the starting IP address and in the text box labeled "IP to (Range)", enter the ending IP address of the range you wish to block. Add a description if wanted and then click the "Add new Block User Rule" button.

I can't install the plugin because the stored procedure won't create/execute (permission problem)

Each web host gives different features and permissions, so I cannot offer much help on this... Please see the following sites: http://dev.mysql.com/doc/refman/5.0/en/stored-routines-privileges.html http://markcordell.blogspot.com/2008/11/mysql-stored-procedure-permissions-and.html http://www.mickgenie.com/blog/mysql-stored-procedures-permission-problem/ Alternatively, try asking your web host to allow you the relevant permissions to create and execute stored procedures.

I'm having trouble with the plugin

Go to the plugin website and post a comment on the simple block page with as much information as possible please.

I can't get anything to work

Sorry, the plugin isn't for you then. Try another plugin.

Requires: 3.0 or higher
Compatible up to: 3.3.2
Last Updated: 2011-2-27
Downloads: 3,628

Ratings

4 stars
4.2 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
33,3,1
100,1,1
50,2,1
0,2,0
33,3,1
100,1,1
100,1,1
100,2,2
100,2,2
100,1,1
100,1,1
100,1,1
100,1,1
0,1,0