WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

VSF Simple Block

VSF Simple Block plugin. Acts as a sort of software firewall.

** If you have an existing installation of this plugin, please make sure you do a database backup before upgrading - Previous versions are available on my blog **

Simple Block does what it says really. It's effectively a software firewall of sorts. Enter an IP Address (or an IP range) or a host or a browser summary into the block rules table and save it. Then watch as visitors that match those entries are bounced and cannot access your site.

Block Rules: IP address is an exact match.
IP range is an exact match to the specified range.
Host is a like match, so if you enter for example google, anything that has google in the host anywhere will be blocked.
Browser summary works just like Host. Add in a value like spider and any hit on your website that contains spider in the browser summary anywhere will be blocked.

In the settings page enter a bounce address of your chosing which will be used to "forward" the users on to if they match a record in the block table.

Filter Rules: There is also a filter table which is read before the bounce address. Values in this allow hits from users that match in exactly the same way as the block table. Because this is queried before the block table any matches will be allowed through.

Block Records: Is a list of all hits that have been bounced and also a single reason why. for example if you have a block record for browser summary - bot - and the google bot arrives on your site, you will get a record that the google bot has been bounced. (I don't recommend blocking the google bot)

Also: Auto block is not (coded) enabled yet. Work in progress.

** Please note that this plugin has the ability to block you if misused! Please be very careful when using this plugin. This plugin requires database rights to create tables and also create and run a stored procedure. Without those database rights this plugin will not be able to function. **

Requires: 3.0 or higher
Compatible up to: 3.3.2
Last Updated: 2011-2-27
Downloads: 3,624

Ratings

4 stars
4.2 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
33,3,1
100,1,1
50,2,1
0,2,0
33,3,1
100,1,1
100,1,1
100,2,2
100,2,2
100,1,1
100,1,1
100,1,1
100,1,1
0,1,0