WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Vim Color Improved

Vim Color Improved is a syntax highlighting plugin that uses vim.

Requirements

This plugin may not work on all php installations. Specifically, there are some access needs that may be locked down on your webserver.

  1. Your webserver must be able to exec(vim) through php
  2. If you want to use remote files, your webserver must be able to open the files through http using file()

To Do List

  1. Add the ability to use vim's options, such as using css, using html, etc...
  2. Add the ability to use WYSIWYG editor for posts, including file selection box for local files.

Version History

v.0.4.0 Bug fixes and new features

  • Fixed problem with files not being found not displaying an error
  • Fixed vim command, was missing last quit
  • Added vci_html_use_css parameter and option
  • Added vim classes to style.css
  • Refactoring of vci_color(), created new methods to decrease the main method size
  • Added vci_link for a default value
  • Added more vim options to the vim command to help performance
  • Added functions.php to include additional functions not directly related to vci
  • Moved temporary directory to the system temp dir to ease installation - no longer need to chmod a directory
  • Attempt auto-detect of vim path using exec('which vim')
  • Added admin css, moved css files to css directory
  • Added management page for cache management
  • Added ability to clear single files from the cache
  • Changed to scroll horizontally by default if code is too wide

v.0.3.2 First Public Version

License

Copyright 2008 Zachary Fox (email : ecommerceninja@gmail.com)

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA

Requires: 2.2.2 or higher
Compatible up to: 2.3.2
Last Updated: 2008-3-5
Downloads: 688

Ratings

0 stars
0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.