WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

VideoSurf Video Link Enhancer

This plugin enhances links to videos with the ability to play the video inline on hover without the reader leaving your page.

Does this work for all videos?

We support videos from hundreds of sites and the list is growing every day. We can only support video sites that have embeddable players. Our index does not contain every video from every site, but our coverage is quite good and we are constantly adding more so if it doesn't work for a particular link, check again later and it will most likely be there.

Can I customize it at all?

Yes! There are a bunch of options you can append to this url.
For more info, visit: http://www.videosurf.com/tools/video-link-enhancer

Highlights include:

  • link_selector_prefix: By default, the script acts on all links on the page. To limit it to only certain areas of your page, you can add a css selector here. This may also have performance benefits. Make sure to url encode any #'s. e.g. link_selector\_prefix=%23content will limit it to only links inside the container on your page with id of "content", or link_selector_prefix=p will limit it to only links inside p tags. We're using JQuery's selector syntax here and will be appending " a" to whatever you provide.
  • link_selector_suffix: In addition to the prefix, you can optionally add a suffix to the link selector. This may be useful if you want to limit the script to act on only links with a certain class or that contain certain text. Again, this uses JQuery's selector syntax.
  • overlay_bg_color: Hex code of what you want the background color to be behind the embed.
  • overlay_text_color: Text color inside the overlay, useful if you change the bg color.
  • add_link_icon: Should we add the little videosurf icon next to each enhanced link? You can change this to "false" to remove it.

Requires: 2.0.2 or higher
Compatible up to: 2.8
Last Updated: 2009-9-24
Downloads: 24,319

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.