WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Tweetable

Integrate Twitter with your WordPress blog. Automatically tweet new posts, display your latest tweet in your sidebar, etc. Uses OAuth for user authent

Version 1.2.8

  • Updated the instructions in the Tweetable setup screens, as they were a bit outdated. If you already have Tweetable installed and working, you can safely skip this update.

Version 1.2.7

  • The Twitter account authorization wizard should now work with the new Twitter API version.

Version 1.2.6

  • Hasty patch to fix Twitter API access, as unversioned endpoints were turned off.

Version 1.2.5

  • Clickability improvements! Thanks to Steffen Vogel for the patch.

Version 1.2.4

  • The plugin repository wasn't updating to show the new documentation changes, so I'm pushing a new version.
  • Added an extra screenshot.

Version 1.2.3

  • Added oEmbed support for Twitter! Now if you paste a properly-formed URL into a post, it will be replaced with an awesome widget from Twitter.

Version 1.2.2

  • Fixed "Missing Argument 2" warning.

Version 1.2.1

  • Made a minor change to the widget-handling code to replace a couple of deprecated functions with their new counterparts.

Version 1.2.0

  • Removed some debugging code. If you are running 1.1.9, please update.

Version 1.1.9

  • Added support for J.mp version 3 of the Bit.ly/J.mp API. Thanks to WordPress.org forum member xeresjp for the patch!

Version 1.1.8

  • Added support for the YOURLS shortener.
  • Changed the shortener API key field (on the settings page) from a "text" to a "password" input.

Version 1.1.7

Tweets with "&" symbols are no longer cut off.

Version 1.1.6

Added a conditional statement to check if the TwitterOAuth class is already included, for compatibility with some other plugins.

Version 1.1.5

  • Added Bit.ly shortener support. (Requires entering your API key.)
  • Added Ow.ly shortener support.

Version 1.1.4

  • Fixed issue where Twitter outages sometimes prevented blogs from loading. (The Latest Tweets widget would trigger a fatal error and end the script.)

Version 1.1.3

  • Added support for StumbleUpon's Su.pr URL shortener.
  • Added a message bubble to the installer when the Twitter account is being changed.

Version 1.1.2

The Change Account link is really fixed now...

Version 1.1.1

Okay, now the Change Account link is fixed...

Version 1.1.0

  • Fixed the Change Account link in the plugin settings.
  • Added three filter hooks to the auto-tweet subroutine.

Version 1.0.9

Fix for the "You do not have sufficient permissions to access this page" error when trying to run the installer under WordPress 2.8.1.

Version 1.0.8

The 1.0.7 update didn't go over properly. Missing files, stuff like that. 1.0.8 should fix any problems.

Version 1.0.7

  • Added #hashtag support. Any hashtags in tweets are made into clickable triggers that open a dialog with a Twitter Search of that hashtag.
  • The "Documentation" link in the Tweetable page footers is now parsed into (much more legible) HTML.
  • Added "Settings" link near the Activate/Deactivate and Edit links on the plugins tab.
  • Updated README, changed "Version History" to "Changelog."

Version 1.0.6

  • Added an option to the widget for a "widget title link," so you can optionally link your widget's title to your Twitter profile.
  • Added an upper limit for the "Number of Tweets to Show" option in the widget (20), to prevent unexpected results if set too high.

Version 1.0.5

  • Auto-tweets no longer show-up in the sidebar widget, as long as you specify a tweet prefix in the settings.
  • Option to exclude Tweetable stylesheet. If you don't display your latest tweets publicly on your blog, why should a stylesheet be included?
  • Added Tweetable "Tweet This" bookmarklet. You can find it on the "Tweet" page.
  • Added "3.ly" to the supported URL shorteners.
  • Added a link to reset the setup wizard if something goes wrong and it doesn't complete.

Version 1.0.4

Fixed error when Safe Mode is on, stopped Shorten URL icon from disappearing when it finished blinking.

Version 1.0.3

Fluid-width dashboard widget (with loading throbber), 140-char limit check when posting updates, AJAX calls include token for security.

Version 1.0.2

Fixed bug triggering fatal error on all installations.

Version 1.0.1

Fixed issue with items on the Track screen not deleting, PHP4 detection problems.

Version 1.0

Initial Release

Requires: 2.8 or higher
Compatible up to: 3.4.2
Last Updated: 2012-10-20
Downloads: 128,503

Ratings

4 stars
4.2 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1
100,1,1 100,1,1
67,3,2
100,1,1 50,2,1
75,4,3 50,2,1
17,6,1
50,2,1
75,4,3
100,1,1
100,1,1
100,1,1
100,1,1
0,1,0
0,1,0
0,2,0 100,1,1
100,1,1 50,2,1
0,1,0 0,1,0
50,2,1
0,1,0
0,1,0