WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Free Tag Manager: Mezzobit Trusted Data Interchange

The free Trusted Data Interchange manages your site's JavaScript data collection tags through a simple web interface without editing templates.

The Mezzobit Trusted Data Interchange (TDI) plug-in permits our tag management system to manage third-party JavaScript data collection tags on your WordPress site. We work with a data privacy non-profit, DataNeutrality.org, to create the Internet's first socially responsible data collection platform, ensuring that your data is handled with care and your users' privacy is respected.

Once you install the plug-in, you can remove all third-party data collection tags and pixels — analytics, social widgets, conversion analysis, etc. — from your website, and insert a single Mezzobit tag.

Using our simple web portal, you can then place tags on your pages and configure them to fire based on your rules without writing a single line of code. Mezzobit also provides complimentary phone consulting to guide customers through implementation. Our tools also can manage your user-facing privacy policies and notices.

  • No worries about your data A data privacy non-profit, DataNeutrality.org, sets Mezzobit’s data management rules and performs continuous compliance checks. Mezzobit customers receive monthly report cards with the results. No secrets here.

  • Improved user experience Third-party tags are prevented from interfering with the rest of the page loading. This allows users to interact with content sooner, increasing conversion and decreasing abandonment. Only tags appropriate for a given page and user are run, further accelerating pages.

  • Launch campaigns faster Deploying new tags for marketing campaigns can be done in minutes, not weeks or months. And changes can be made on the fly, permitting greater marketing agility and faster time to market.

  • Less technical support Once our tag is embedded in your webpage, you never need to touch it again. WordPress users can install our plug-in for even speedier deployment. Implementation, maintenance and testing can done with minimal developer involvement.

For more information, please visit our websiteor view our brief video explaining our dot-com/dot-org advantage.

Requires: 3.0.1 or higher
Compatible up to: 3.9.1
Last Updated: 2014-5-14
Downloads: 371

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2