WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

trung_presszen

This is an extension for WordPress to integrate ZenPhoto into your WordPress installation. INSTRUCTION CHANGED FOR ZP 1.1.7

This is an extension for WordPress to integrate ZenPhoto into your WordPress installation. It required ZenPhoto installed on the same server and very easy to install (thanks to WordPress easy plug-in system).

There is one minor conflict in 2 systems in gettext functions, you will have to modify 2 lines of code in Zenphoto to make this work. No danger at all.

Installation : ATTENTION : FROM VERSION 1.1.7 OF ZENPHOTO, STEP 2 ARE NOLONGER REQUIRED, SKIP IT IF YOUR ZP VERSION > 1.1.7 1. Download the zip file and extract to WordPress plug-in directory.

  1. Edit {ZENPHOTO}/zp-core/lib-gettext/gettext.inc

About line 33, replace

require('streams.php'); require('gettext.php');

with if (!class_exists('StreamReader')) { require('streams.php'); } if (!class_exists("gettext_reader")) { require('gettext.php'); }

and about line 190:

replace

function __($msgid) {

return _gettext($msgid); }

with if (!function_exists('__')) { function __($msgid) {

return _gettext($msgid); } }

  1. Go to wordpress admin page, activate the plug-in, then go to Trung_ZenPress Configuration under plug-in tab, fill in the required information .

    • Zenpath : Path to zenphoto installation
    • Slug : the slug name of the page you want to be gallery (create a page and fill its slug here)

There you go, ZenPhoto is resided in your wordpress page.

Requires: 2.2 or higher
Compatible up to: 2.5
Last Updated: 2008-7-14
Downloads: 1,326

Ratings

1 star
1 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0