WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

TinyMCE Tabfocus Patch

Disables TinyMCE plugin Tabfocus thereby allowing tab characters to be typed into posts.

The TinyMCE Tabfocus Patch is a WordPress plugin which disables TinyMCE plugin Tabfocus thereby allowing tab characters to be typed into posts.

While attempting to write several posts including blocks of code I realized that TinyMCE was stripping out all the tab characters I attempted to type. Although I could type tab characters in HTML mode, switching between HTML and Visual removed the tab characters, infuriating me. I use CodeColorer for code coloring, and as the plugin also converts tabs to non-blocking spaces automatically I don't want tab characters that I paste in to get stripped.

After searching for the cause of this issue I realized that the cause was the tabfocus TinyMCE plugin. Rather than going into post.php and manually removing the TinyMCE plugin from the list of plugins to be automatically loaded, I wrote this WordPress to handle it for me.

This plugin should work with TinyMCE, TinyMCE Advanced, and most other TinyMCE mods out there.

Special thanks to Mike Walker's TinyMCE Entities Patch which provided the basis for understanding how to hook the necessary section of code to solve the problem.

Requires: 2.8 or higher
Compatible up to: 2.9.2
Last Updated: 2010-2-14
Downloads: 3,445

Ratings

4 stars
4 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1