WordPress.org

Ready to get started?Download WordPress

Plugin Directory

This-or-That

Let your visitors vote between posts and images to create honest rankings. Uses the ELO Algorithm and works with your site's existing content.

Inspired by Facemash, Facebook's predecessor, this plugin sets up two items next to each other and lets visitors choose which one they favor. Each 'vote' adjusts the rating of both items. You can then easily create lists with your visitors favorite items.

See this plugin in action.

Works with content already on your site!

Start by using what you've already got. The This-or-That plugin works with any post type already on your website like your blog posts, photos, recipies, or WooCommerce products.

Item Manager

If you want to keep your This-or-That items seperate thats no problem. This plugin creates a seperate section in your Admin where you can create and manage your 'This-or-That' items. You can even sort them by ranking, wins, and losses.

Easy Implementation

If you've added some This-or-That items, the only thing left to do is add the shortcode [thisorthat] to a page. Displaying the ranking lists is just as easy: [thisorthat_ranking]. Please see the FAQ for some extra options like showing post-types or categories.

Elegant AJAX Interface

The plugin comes with an elegant, user-friendly voting interface. Items will automatically get updated without a page-refresh and you can even vote using your left and right keys on your keyboard.

Create Lists per Category

Show lists from your different categories or custom taxonomies.

Uses the ELO Rating system

This-or-That uses the ELO Rating System, created to rank chess players but now used in a variety of fields.

Be Creative!

There are plenty of ways to use this plugin; get some insight in what your visitors like or let them engage with your sites content. Some stuff you might want to use this plugin with:

  • Recipies
  • Woocommerce Products
  • Holiday Images
  • Simpsons Episodes
  • Design Proposals
  • Artworks
  • Books
  • Etc...

Read more on the plugin website.

Requires: 3.7.1 or higher
Compatible up to: 3.7.1
Last Updated: 2013-12-8
Downloads: 1,135

Ratings

4 stars
4.5 out of 5 stars

Support

0 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1