WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Taxonomy List Shortcode

The Taxonomy List Shortcode plugin adds a shortcode to your WordPress installation which enables you to display multiple unordered lists containing ev

0.9

  • Replaced is_taxonmy() with taxonomy_exists() for WordPress 3.0.
  • Defined taxonomy_exists() for 2.9 branch.
  • Added edit links to the terms lists.
  • show_all argument has been added to shortcode. It is set to false by default.
  • Tested in 3.0-RC3 using the TwentyTen theme.
  • Shortcode's 'args' argument has been removed.
  • Pad counts is now always set to true for get_terms().

0.8.1

  • Fixed bug in form control for css toggle.

0.8

  • Added Support for paging via the per_page parameter.
  • Added cutom subpage under "Settings" called "Taxonomy" for 3.0 support. They killed "Miscelaneous" where our setting used to live.
  • Changed the name of the CSS setting in the database. Sorry, it won't happen again :)

0.7

  • Allowed for disabling of term counts via the show_counts argument. Props to nicolas for the suggestion.

0.6

  • Added parameters for background and color.
  • CSS bug fixes.
  • Tested in 3.0 Beta.

0.5

  • Main plugin file's name has been changed from "mf-taxonomy-list-shortcode.php" to "taxonomy-list-shortcode.php".
  • Style tag has been optimized to only use one line when rendered.
  • No longer using an object.
  • Removed the include_css() function.
  • Added option for CSS. This can be Set under Miscellaneous -> "Enable CSS for Taxonomy List Shortcode Plugin".
  • Added PhpDoc style comments to code.
  • Added "args" attribute to the shortcode.

0.4

  • pad_counts is now set to true by default for get_terms();

0.3

  • PHP Bugfix with empty array being passed to array_chunk().

0.2

  • Added the sanitize_cols() method.

0.1

  • Original Release - Works With: wp 2.8.6 + wp 2.9 beta 2.

Requires: 2.8.6 or higher
Compatible up to: 3.0-RC3
Last Updated: 2010-6-14
Downloads: 4,125

Ratings

4 stars
4.7 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1
100,1,1 100,2,2
100,1,1 100,1,1
100,1,1 100,1,1
100,3,3
67,3,2
100,1,1
100,1,1
100,1,1
0,1,0
100,1,1