WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

SyntaxHighlighter Plus

Easily post source code such as PHP or HTML and display it in a styled box.

Updgrading From A Previous Version

To upgrade from a previous version of this plugin, delete the entire folder and files from the previous version of the plugin and then follow the installation instructions below.

  • Starting from WordPress 2.7, plugin upgrades are handled by WordPress, there is no need to manually upload files.

Important: If you have made any changes to the CSS file, please make sure to back it up before upgrade!

Uploading The Plugin

Extract all files from the ZIP file, making sure to keep the file structure intact, and then upload it to /wp-content/plugins/.

This should result in the following file structure:

- wp-content
    - plugins
        - syntaxhighlighter-plus
            | readme.txt
            | syntaxhighlighter.php
            - syntaxhighlighter
                - scripts
                    | clipboard.swf
                    | shBrushBash.js
                    | shBrushCpp.js
                    | shBrushCSharp.js
                    | [...]
                    | shCore.js
                    | shLegacy.js
                - src
                    | shCore.js
                    | shLegacy.js
                - styles
                    | SyntaxHighlighter.css

See Also: "Installing Plugins" article on the WP Codex

Plugin Activation

Go to the admin area of your WordPress install and click on the "Plugins" menu. Click on "Activate" for the "SyntaxHighlighter" plugin.

Plugin Usage

Just wrap your code in [sourcecode language='css']code here[/sourcecode]. The language attribute is required! See the plugin's description for a list of valid language attributes.

Requires: 2.0 or higher
Compatible up to: 2.7.x
Last Updated: 2009-2-11
Downloads: 28,008

Ratings

3 stars
3.9 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
50,2,1
100,3,3
0,2,0
0,1,0
100,1,1
100,1,1
100,1,1
50,2,1
0,1,0
100,1,1