WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Smartlinker

Smartlinker is a toolbar on the WordPress TinyMCE editor that enables you to hyperlink words and phrases in your blog.

How does the hyperlinking work?

Select Word→Right Click→Hyperlink. Or Select Word→Press Smartlink button→Hyperlink. If the word/phrase is present in the inetlinker database, a list of hyperlinks will be displayed. Click on the Preview/Hyperlink at the right(or left, wherever space) of each hyperlink.

What criteria was used to "pre-select" the url (or hyperlink) for a term?

The web pages have been "crawled" from the world wide web.

The choice of a web site is guided by criterias like availibility of a picture describing the word, quality of description, formatting and lack of advertisements/popups on the web page. The objective is to pick urls which point to web pages that have an "educational" feel. The hyperlinks are not ads.

What browsers are currently supported?

IE 6/7/8 on Windows and Firefox 3.x on Windows/Linux/Mac OS.

When I try to hyperlink, the "Link Status Indicator" button gives me "JSonRequestError: Bad Response" (Firefox) or "Bad Response" (IE)

There are temporary connectivity issues with the http://www.inetlinker.com server or the server is down. Please refresh the browser and re-try again after sometime.

I cannot see the Smartlinker plugin on WordPress after activating the plugin. Why?

Please try refreshing the browser on the WordPress Editor after enabling the plugin from the "Plugins" screen. If it still does not work, close all browser windows, remove the "smartlinker" directory from the "wp-content/plugins" directory, and reinstall the plugin from http://wordpress.org/extend/plugins/smartlinker/. That should do it.

Where do I report a bug?

Bugs can be reported at support@inetlinker.com.

Requires: 2.7 or higher
Compatible up to: 3.2.1
Last Updated: 2011-9-23
Downloads: 10,680

Ratings

4 stars
4.7 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,3,3
75,4,3
100,2,2
50,2,1