WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Smart Video

A plugin for WordPress to display flash videos. Such as TuDou, QQ Video, Ku6, Sina Video, YouKu, Sohu Video, YouTube, Vimeo, Mofile and so on.

  1. Search for Smart Video in the Plugins menu to install.
  2. Or upload folder smart-video to the /wp-content/plugins/ directory.
  3. Activate Smart Video through the 'Plugins' menu in WordPress.
  4. Place the code such as [youtube id=fY4Epc2XSGc ] in your post, or just use the Magic Insert in TinyMCE, and then publish it.

Usage

  1. In TinyMCE: Click the icon of Smart Video, in the popup window, there're 3 tabs.

1.1 Magic Insert: You can input the page url such as http://www.youtube.com/watch?v=fY4Epc2XSGc. After you click "Insert", it will be translated into short tags as [youtube id=fY4Epc2XSGc ].

1.2 Manual Insert: In this tab, you should find the video ID by yourself. The ID is the part marked with "{}" as follow:

http://v.ku6.com/show/`{nNjHZUTAi79x3atP}`.html
http://v.youku.com/v_show/id_`{XMTE2ODE2MjUy}`.html
http://www.tudou.com/programs/view/`{J-2bug0o0u4}`/
http://video.qq.com/v1/videopl?v=`{6mkvdlafJbU}`
http://you.video.sina.com.cn/b/`{24114739}`-1371694022.html [vimeo http://www.vimeo.com/`{5606758}` ] http://v.blog.sohu.com/u/vw/`{3151517}`

1.3 Insert Flash: You can insert flash by specifying the url and the size (size if optional).

  1. In Code View: Of cause you can input all the code by hand. Short tags are as follows:

    [ku6 id="{id}" h="{height}" w="{width}"] [youku id="{id}" h="{height}" w="{width}"] [tudou id="{id}" h="{height}" w="{width}"] [qq id="{id}" h="{height}" w="{width}"] [youtube id={id} h={height} w={width} ] [sina id="{id}" h="{height}" w="{width}"] [sohu id="{id}" h="{height}" w="{width}"] [vimeo id={id} h={height} w={width} ] [flash url="{url}" h="{height}" w="{width}"]

Requires: 2.5.0 or higher
Compatible up to: 2.9.2
Last Updated: 2010-1-19
Downloads: 19,041

Ratings

4 stars
4.4 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,4,4
0,2,0
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1