WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Simply Poll

Simply, it adds polling functionality to your WordPress site

1.4.1

  • Fixed issues from SVN update

1.4

  • Fixed a number of bugs posted in the forum
  • Added Logger to allow easier debugging
  • Improved AJAX request (no longer using wp-load.php)
    • This has fixed PHP warnings to do with headers being sent already
  • Improved PHP and JS docs
  • Improved names in CSS for less issues with native style-sheets
    • Also moved the location of the CSS files to their relevant theme folders
  • Renamed the page folder to view
  • Renamed the user folder to client

1.3.4

  • Added translation support
  • Polls now appear where short code is in content

1.3.3

  • Fixed database creation issues and display SQL query to use if an error

1.3.2

  • Fixed repo missing poll-submit.php

1.3.1

  • Repo fixed
  • Minor CSS changes

1.3

  • Added plugin URI
  • Added file 'poll-submit.php' to replace poll-results.php
  • Added wp_enqueue_script('jquery'); when shortcode is used
  • Added jQuery Validation Plugin for admin
  • Added jqPlot for admin results
  • Added admin CSS
  • Added default poll CSS
  • Added page/user/poll-results.php to allow custom styling of poll results
  • Added support for none JS clients
  • Removed "ENGINE = MYISAM' from the database install
  • Removed "CHARSET = UTF-8" from database install and now using get_bloginfo('charset')
  • Updated file poll-submit.php to a better structure
  • Updated the SP_URL constant to combat x-domain issues
  • Updated the admin interface
  • Fixed issue where cookie is set but poll option not selected
  • Fixed issue where poll results wouldn't display after submit
  • Improved code layout
  • Improved the poll add/edit script

1.2

  • Skipped, 1.3 update was more significant

1.1

  • Fix the limiting

1.0

  • Initial release

Requires: 3.0 or higher
Compatible up to: 3.3.2
Last Updated: 2012-1-5
Downloads: 21,538

Ratings

3 stars
3.3 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,2,2 100,4,4 0,2,0 50,2,1 0,1,0 100,1,1 0,1,0 0,1,0
0,1,0
0,1,0 38,8,3
100,1,1
0,1,0
0,2,0
100,1,1
100,1,1
0,1,0
100,1,1