WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Scripts n Styles

This plugin allows Admin users to individually add custom CSS, Classes and JavaScript directly to Post, Pages or any other custom post types.

This plugin allows Admin users the ability to add custom CSS and JavaScript directly into individual Post, Pages or any other registered custom post types. You can also add classes to the body tag and the post container. There is a Global settings page for which you can write Scripts n Styles for the entire blog.

Admin's can also add classes to the TinyMCE "Formats" dropdown which users can use to style posts and pages directly. As of Scripts n Styles 3+ styles are reflected in the post editor.

Because only well trusted users should ever be allowed to insert JavaScript directly into the pages of your site, this plugin restricts usage to admin type users. Admin's have access to even more sensitive areas by definition, so that should be relatively safe ;)

Notes about the implementation:

  • Admin users, or more specifically, any user with the manage_options and unfiltered_html capabilities (which by default is only the admin type user) can use this plugin's functionality. Some plugins extend user rolls, and so this plugin would naturally extend include rolls that have the appropriate capability.
  • CSS Styles are embeded, not linked, at the bottom of the head element with style tags by using wp-head. If your theme doesn't have this hook, this plugin (as well as most others) won't work.
  • JavaScript is embeded, not linked, at the bottom of the body (or head) element with script tags by using wp-footer (or wp-head). If your theme doesn't have this hook, this plugin (as well as most others) won't work.
  • There is no input validation. This plugin puts exactly what you type in the meta box directly into the html with no error checking. You are an Admin, and we trust you to be carefull. Try not to break anything.
  • Do to the licensing of the libraries used, this plugin is released "GPL 3.0 or later" if you care about those things.

Contact:

You'll have better luck contacting the other if you try me on Twitter and Github. If that fails, I have an open thread on the support forums that will trigger an email.

Requires: 3.6 or higher
Compatible up to: 3.6.1
Last Updated: 2012-7-12
Downloads: 11,592

Ratings

4 stars
4.9 out of 5 stars

Support

0 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1 100,1,1 100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1 100,1,1
100,1,1 100,1,1
100,1,1 100,1,1
0,1,0 100,1,1
100,1,1
0,1,0 100,1,1 100,1,1 100,1,1
0,1,0 100,1,1 100,1,1 100,1,1 100,1,1 100,1,1 0,1,0 100,1,1
100,1,1 100,1,1 0,1,0 100,1,1
100,1,1 100,2,2
100,1,1 100,1,1 100,3,3
100,1,1 100,1,1 100,1,1
100,1,1 100,1,1
100,2,2
100,1,1
100,1,1
100,1,1
100,1,1 100,1,1