WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

runPHP

Allow users to embed PHP code in their posts or pages.

Caveats and Gotchas

  • Code executed by runPHP is not in the global scope. It is executed as if it were inside a function block and so you'll need to declare your globals accordingly. (This is a limitation of PHP's eval() function, not the plugin itself.)
    • Some people have reported seeing an error message of "unexpected T_OBJECT_OPERATOR" in the runPHP_options_ui.inc.php file. I think this is because of how PHP4 handles objects - will you add a comment (preferably in this forum thread) about what version of PHP your website is using?
    • With few badly written WordPress themes, the plugin does not work. This is caused by a missing wp_head() call in the theme's header template (often called header.php). If that is the case, fixing it is simply a matter of inserting at the right point in the php template. See (http://squio.nl/blog/2006/11/08/wp-themes-and-microsummary-plugin/) for more details.

Thanks for using this plugin - I hope it helps!

Requires: 2.0 or higher
Compatible up to: 2.2.1
Last Updated: 2007-8-17
Downloads: 31,755

Ratings

4 stars
4.6 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
50,2,1
0,1,0
0,1,0
0,2,0
0,1,0
100,1,1
0,1,0