WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Rename wp-login.php

Change wp-login.php to anything you want. It can also prevent a lot of brute force attacks.

2.3

  • WordPress 3.9 compatible.
  • Fix issue where the slug reverts to default when saving the permalink structure.

2.2.4

  • Fixed SSL issues.
  • Set REQUEST_URI back.
  • Check if wp-login.php functions exist to avoid future fatal errors.

2.2.3

  • Fixed URL filters.

2.2

  • Fixed issue where requests redirect to the new login page.
  • Trailing slash based on the permalink structure.

2.1

  • Works now with non-pretty permalinks!
  • Gives a message when using W3 Total Cache or WP Super Cache to update options.

2.0.1

  • Prevents pretty redirects such as /login and /admin.
  • Simplifies some code.
  • Forces login page with trailing slash.
  • Replaces a wp_redirect with wp_safe_redirect.
  • Shows error message in the network admin if permalinks are not enabled for the main site.

2.0

  • This plugin can now be activated for a network and a networkwide default can be set.
  • The plugin now hooks in after init to make sure any customisations to the login form are hooked in before it.
  • Links should now be fixed when SSL is enabled.

1.9

  • wp-admin will now have a wp_die() message instead of a 404 template because this caused problems.
  • Minimum version is now 3.8.
  • Added updates from wp-login.php in 3.8.

1.8

  • OOP PHP.
  • Requires WordPress 3.7 or higher.
  • MultiViews compatible.

1.7

  • Made compatible with WordPress 3.7.

1.6

  • Fixed the login link when site_url()home_url().
  • Added a mirror on GitHub.

1.5

1.4

  • Faster page load.
  • Fixed 404 error for permalink structures with a prefixed path. “Almost pretty” permalinks work now too.
  • Code clean-up.

1.3

  • Prevents the plugin from working when there is no permalink structure.

1.2

  • Fixed status code custom login page.

1.1

  • Blocked access to wp-admin to prevent a redirect the the new login page.

1.0

  • Initial version.

Requires: 3.8 or higher
Compatible up to: 3.9
Last Updated: 2014-3-16
Downloads: 40,777

Ratings

4 stars
5 out of 5 stars

Support

15 of 32 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1 100,2,2 100,1,1 100,3,3 100,1,1 100,2,2
100,2,2 100,3,3
0,3,0 100,2,2
100,4,4 83,6,5
0,1,0 100,1,1 100,1,1 100,1,1 100,1,1 100,3,3 100,1,1 100,1,1 100,1,1
100,1,1 0,1,0 100,3,3 100,4,4 100,6,6