WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Post Thumbnail Editor

Fed up with the lack of automated tools to properly crop and scale post thumbnails? Maybe this plugin can help.

Usage

  1. Start with the Media Library
    1. Open Media Library
    2. Click the "Thumbnail" link in the rollover options.
  2. or start within image editor interface (when viewing image details)
    1. Click "Edit Image"
    2. Click the "Post Thumbnail Editor" link under the other thumbnail options.
  3. Using Post Thumbnail Editor Interface
    1. Select the thumbnails you want to edit. If a thumbnail defines a specific aspect ratio it will be applied to the editor. If you select thumbnails with different aspect ratios (width / height), this feature is disabled. Be careful or you might make some of your pictures look funny.
    2. Select the cropped/scaled area, by clicking and dragging on the left-hand image.
    3. Click the "Crop" button.
    4. Use the save icon to save the pictures, or use the view tab to compare the old and new versions before you commit.
  4. It's possible that you might have to refresh the cache (ctrl+f5 on the page) to see changes, but they should be there.

Did you even test this?

Yes. No. Sort of. Thanks for asking. But let me know if you're having problems and I'll see what I can do.

So it's installed but it doesn't appear to be working, how do I troubleshoot the problems?

Before posting a question or requesting support, disable all other plugins to verify that the problem isn't caused by some esoteric conflict. If you find a conflict with another plugin, let me know and I will fix it.

If you want to post a problem on the support forums or at github please include the following information:

  1. What browser (and version) are you using, or which browsers have you seen the behavior in?
  2. What wordpress version are you using?
  3. Does the javascript console report any exceptions/errors?
    • Google Chrome: ctrl+shift+j
    • Firefox: ctrl+shift+j
    • IE: F12 to open developer tools, click on the "Script" tab and view the "Console" sidebar.
  4. Detail the steps to reproduce your problem
    • What did you do?
    • What did you expect to happen?
    • What actually happened?

Requires: 3.5 or higher
Compatible up to: 3.9.x
Last Updated: 2014-4-26
Downloads: 125,098

Ratings

4 stars
4.7 out of 5 stars

Support

6 of 7 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

2 people say it works.
0 people say it's broken.

50,2,1 100,4,4
100,1,1
100,2,2 0,1,0
0,1,0 100,3,3
100,2,2 100,1,1
100,1,1 50,2,1
100,1,1 43,7,3 0,1,0 100,1,1 100,3,3 83,6,5
100,1,1 60,5,3
100,1,1 64,11,7
100,1,1 92,12,11
100,2,2
100,8,8
83,6,5
0,4,0 71,7,5
20,5,1 25,4,1 100,1,1 100,3,3 100,1,1 100,2,2 100,1,1 100,1,1
100,1,1
100,1,1
100,2,2
100,2,2
75,4,3
33,3,1 100,1,1
100,4,4
100,1,1
100,5,5
100,2,2