WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Ostrichcize

Hide PHP error reporting for specified plugins or the current theme.

Is there a UI to add ostrichcize rules?

No. At this time, I really only want developer's using this tool. Any WordPress developer that is messing with error handling should easily be able to make this plugin work. If not, the developer should not be using this tool. Similarly, users should not be messing with error reporting.

Can I run this in production?

You certainly can, but that is not the intent of the tool. It is best to only run this in development.

What is the use case?

This plugin is inspired by having installed countless plugins that throw error notices. Many times, these are small, non-critical errors. Since I often do not have time to fix the errors myself, I allow them to continue to muck up my error logs or on screen display of errors. I thought it would be nice to have a way to hide these errors so that only errors due to my custom code are displayed. Ostrichcize allows you to do just that.

Requires: 3.3 or higher
Compatible up to: trunk
Last Updated: 2012-11-24
Downloads: 273

Ratings

0 stars
0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1