WordPress.org

Ready to get started?Download WordPress

Plugin Directory

New User Approve

New User Approve is a WordPress plugin that allows a blog administrator to approve a user before they are able to access and login to the blog.

Other Notes

The code for this plugin is also available at Github - https://github.com/picklewagon/new-user-approve. Pull requests welcomed.

Filters

  • new_user_approve_user_status - modify the list of users shown in the tables
  • new_user_approve_request_approval_message - modify the request approval message
  • new_user_approve_request_approval_subject - modify the request approval subject
  • new_user_approve_approve_user_message - modify the user approval message
  • new_user_approve_approve_user_subject - modify the user approval subject
  • new_user_approve_deny_user_message - modify the user denial message
  • new_user_approve_deny_user_subject - modify the user denial subject
  • new_user_approve_pending_message - modify message user sees after registration
  • new_user_approve_registration_message - modify message after a successful registration
  • new_user_approve_register_instructions - modify message that appears on registration screen
  • new_user_approve_pending_error - error message shown to pending users when attempting to log in
  • new_user_approve_denied_error - error message shown to denied users when attempting to log in

Actions

  • new_user_approve_user_approved - after the user has been approved
  • new_user_approve_user_denied - after the user has been denied
  • new_user_approve_approve_user - when the user has been approved
  • new_user_approve_deny_user - when the user has been denied

Translations

The plugin has been prepared to be translated. If you want to help to translate the plugin to your language, please have a look at the localization/new-user-approve.pot file which contains all definitions and may be used with a gettext editor like Poedit (Windows). More information can be found on the Codex.

When sending me your translation files, please send me your wordpress.org username as well.

Requires: 3.5.1 or higher
Compatible up to: 3.9.1
Last Updated: 2014-4-17
Downloads: 91,287

Ratings

4 stars
4.4 out of 5 stars

Support

9 of 13 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1
100,1,1 100,1,1
100,1,1 100,1,1 100,2,2
100,2,2
70,10,7
100,1,1
0,4,0
0,1,0
100,1,1
67,6,4
100,2,2
67,6,4
0,1,0 50,2,1
67,3,2 100,1,1
100,1,1 100,2,2 0,1,0
0,1,0
50,2,1
0,1,0 0,1,0 0,1,0
0,1,0 100,1,1 100,1,1
0,1,0
100,1,1
100,1,1