WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

MyCaptcha

Allows you to display a captcha on your comment form to avoid spam.

Is it possible to extend the library of captchas ?

In the folder MyCaptcha/php/crypt/cfg/default , you will find 4 more folders (blackwhite, classic, psychedelic, small). Some of these styles are not in the original config because they are using licensed fonts (#) that cannot be provided by this plugin.

  • blackwhite is using (#)arial font (line 73 of cryptographp.cfg.php)

  • classic is using (#)verdana font (line 73 of cryptographp.cfg.php)

  • small is using (#)times font (line 73 of cryptographp.cfg.php)

  • psychedelic is using luggerbu and looks ugly for me (line 69 of cryptographp.cfg.php)

You may have already paid for these **licensed fonts if they are genuine with your computer or your softwares.

so to install one or several new styles do as follow

For each style

  1. copy the folder (blackwhite,classic, ...) to MyCaptcha/php/crypt/cfg .
  2. copy the 'MyCaptcha style' requested font file in the MyCaptcha/php/crypt/fonts folder. (you should find it on your computer)
  3. in MyCaptcha/php/crypt/fonts check and/or modify 'php fonts.php' file accordingly.

Once you've finished to install all your styles, edit MyCaptcha.php (main plugin file)

The line 15 of this file ( $this->ver = '2.5'; ) should be modified in ( $this->ver = '2.50000001'; )

if you have to repeat this operation don't forget to increment $this->ver.

If every thing was done by the book, you should have the MyCaptcha setting panel modified accordingly.

Is it possible to delete captcha styles from the library ?

  1. READ the previous question and its answer,
  2. Replace the For each style all steps by the following step :
    • Delete the appropriate Captcha folder in MyCaptcha/php/crypt/cfg
  3. Don't forget to increment $this->ver.

Requires: 2.5 or higher
Compatible up to: 2.5
Last Updated: 2008-4-21
Downloads: 14,276

Ratings

4 stars
4.1 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,1,1