WordPress.org

Ready to get started?Download WordPress

Plugin Directory

MimeTypes Link Icons

Adds icons automatically to any uploads and/or file links inserted into your blog posts.

MimeTypes Link Icons is a plugin that looks for links to files and uploads in your blogs posts and adds a nice icon next to it. Optionally add the file's file size next to the link.

Important note on v3.0 and up: This version partially breaks backwards compatibility: the plugin now requires PHP5.1+ and WP 3.5+. Please have a look at the changelog for more information about the changes.

The icons are configurable. You can choose to display a PNG with transparent background or GIF with white matte, display the icon to the left or the right of the link and choose the icon size.

Each icon is available in the following sizes:

  • 16x16px
  • 24x24px
  • 48x48px
  • 64x64px
  • 128x128px

Supported File Extensions

  • .3g2
  • .3gp
  • .ai
  • .air
  • .asf
  • .avi
  • .bib
  • .cls
  • .csv
  • .deb
  • .djvu
  • .dmg
  • .doc
  • .docx
  • .dwf
  • .dwg
  • .eps
  • .epub
  • .exe
  • .f
  • .f77
  • .f90
  • .flac
  • .flv
  • .gif
  • .gz
  • .ico
  • .indd
  • .iso
  • .jpg
  • .jpeg
  • .log
  • .m4a
  • .m4v
  • .midi
  • .mkv
  • .mov
  • .mp3
  • .mp4
  • .mpeg
  • .mpg
  • .msi
  • .odp
  • .ods
  • .odt
  • .oga
  • .ogg
  • .ogv
  • .pdf
  • .png
  • .pps
  • .ppsx
  • .ppt
  • .pptx
  • .psd
  • .pub
  • .py
  • .qt
  • .ra
  • .ram
  • .rar
  • .rm
  • .rpm
  • .rtf
  • .rv
  • .skp
  • .spx
  • .sql
  • .sty
  • .tar
  • .tex
  • .tgz
  • .tiff
  • .ttf
  • .txt
  • .vob
  • .wav
  • .wmv
  • .xls
  • .xlsx
  • .xml
  • .xpi
  • .zip

Localization

Please help make this plugin available in more languages by translating it. The translation files are included in the download. See the FAQ for more info.

Requirements

Since version 3.0, the plugin now requires PHP5.2+ and WP 3.5+. The PHP filter extension needs to be enabled as well.

Need more ?

If you need support for this plugin or even want a completely different plugin programmed: hire Toby or Juliette!

Requires: 3.5 or higher
Compatible up to: 3.9.2
Last Updated: 2014-6-10
Downloads: 46,961

Ratings

4 stars
4.9 out of 5 stars

Support

2 of 4 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1
100,1,1
0,3,0
100,2,2
100,2,2
100,1,1
100,1,1 100,1,1 0,1,0 100,1,1
100,1,1
100,1,1 100,3,3 100,1,1
50,2,1
67,3,2 100,2,2 100,1,1 100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,3,3
100,3,3
100,1,1