WordPress.org

Ready to get started?Download WordPress

Plugin Directory

MailChimp List Subscribe Form

The MailChimp plugin allows you to quickly and easily add a signup form for your MailChimp list.

1.4.1

  • Update styles to be compatible with upcoming 3.8 wp-admin changes

1.4

  • Developer Mode "Kitchen Sink" takes over plugin for local development
  • Developer Mode has filters of changable content
  • Fix bug related to required US phone validation

1.3

  • Now using OAuth flow for user authentication
  • Admin UI refresh

1.2.14

  • Add link to edit profile within error when duplicate signup occurs

1.2.13

  • Fixed bug preventing address fields from submitting correctly.

1.2.12

  • Update spanish language files (es_ES and es_MX)

1.2.9

  • Fixed bug where multiple checkbox type interest groups were returning an invalid error
  • Fixed bug where assets were not enqueueing properly if the plugin directory was not set to 'mailchimp'. Now supports any directory name.

1.2.8

  • Fixed bug where entire phone numbers were only being deposited in the area code portion

1.2.7

  • CSS should now always load correctly on the front end
  • Adding Hebrew and Romanian language support
  • Updating translation contribution instructions
  • Tested version is now 3.3.1

1.2.6

  • Fixed bug with "Settings" link appearing on all plugins (props Jason Lane)
  • Resolved issue with unnecessary calls to the MailChimp API during upgrade check
  • Resolved PHP warning when there weren't any interest groups

1.2.5

  • Field formatting based on type
  • Support for multiple interest groups (a data upgrade procedure must be run by visiting the WordPress dashboard)
  • Added jQuery datepicker option to be used with dates.
  • Added a handful of new translations
  • Fixing various PHP notices and deprecated functions (props Jeffry Ghazally)

1.2.4

  • Version bump for proper listing on wordpress.org

1.2.3

  • Change mailchimpSF_where_am_i() to use plugins_url() in place of WP_PLUGIN_URL to take SSL into account when delivering assets (props John LeBlanc)
  • Update MCAPI wrapper to bring back PHP4 support (note: PHP 5.2 to be required starting with WordPress 3.2)

1.2.2

  • Change MCAPI wrapper to use a more unique class name, v1.3 of the API, and a much lighter client library

1.2.1

  • Fixed internationalization path bug.
  • Fixed instances where i18n functions weren't necessary in admin.
  • Added more strings to be translated.

1.2

  • Recommended Upgrade, please see "Upgrading" section of readme.
  • Security and various other improvements

Requires: 2.8 or higher
Compatible up to: 3.7.1
Last Updated: 2013-11-21
Downloads: 729,815

Ratings

3 stars
3 out of 5 stars

Support

11 of 50 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0
100,2,2
0,1,0
0,1,0 33,3,1
50,6,3
67,3,2 0,3,0
100,2,2 100,2,2
40,10,4 63,8,5 67,3,2
33,3,1
100,1,1 33,3,1
100,1,1 20,5,1
100,1,1 33,24,8
100,2,2 100,1,1 50,6,3
33,3,1
100,3,3
100,1,1
100,1,1
91,11,10 20,45,9 29,7,2
100,5,5
14,21,3 83,6,5 60,5,3 100,1,1
57,7,4
100,1,1 100,1,1 100,1,1 0,1,0
100,1,1 100,6,6
100,2,2 100,4,4 50,2,1
60,5,3
83,6,5 88,8,7
100,1,1
100,2,2 100,1,1
0,1,0 50,2,1
50,2,1 0,2,0
33,9,3
50,6,3
100,1,1