WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

LiberatID

Allow user login or registration using LiberatID service. Additionally, OpenIDs for authentication of users and comments is also supported.

Why do I get blank screens when I activate the plugin?

In some cases the plugin may have problems if not enough memory has been allocated to PHP. Try ensuring that the PHP memory_limit is at least 8MB (limits of 64MB are not uncommon).

Why don't `https` OpenIDs work?

SSL certificate problems creep up when working with some OpenID providers (namely MyOpenID). This is typically due to an outdated CA cert bundle being used by libcurl. An explanation of the problem and a couple of solutions can be found here.

Why do I get the error "Invalid openid.mode ''"?

There are actually a couple of reasons that can cause this, but it seems one of the more common causes is a conflict with certain mod_security rules. See this blog post for instructions on how to resolve this issue.

How do I use SSL for OpenID transactions?

First, be aware that this only works in WordPress 2.6 and up. Make sure you've turned on SSL in WordPress by defining either of the following globals as "true" in your wp-config.php file:

  • FORCE_SSL_LOGIN
  • FORCE_SSL_ADMIN

Then, also define the following global as "true" in your wp-config.php file:

  • OPENID_SSL

Be aware that you will almost certainly have trouble with this if you are not using a certificate purchased from a well-known certificate authority.

How do I get help if I have a problem?

Please direct support questions to the "Plugins and Hacks" section of the WordPress.org Support Forum. Just make sure and include the tag 'liberatid' so that we'll see your post. Additionally, you can report a bug at http://liberatid.com/contact.html.
Also, you can send an email to support@liberatid.com.

Requires: 2.8 or higher
Compatible up to: 3.2.1
Last Updated: 2011-11-29
Downloads: 279

Ratings

0 stars
0 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1