WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Language Code Classification

This plugin adds the ability to add an ISO 639-3 language code to the custom field of a post.

0.1.3: CURRENT VERSION

  • bug fix: changed the plugin folder name from language_code to language-code to follow WP Extend conventions. This also affected several paths to. js files.

0.1.2:

  • Promoted at the WordPress Plugin Database as 0.1.2 beta
  • The autocomplete seems to work better now. Can do accent/case insensitive searches.

    • fixed bug for MYSQL SELECT query for searching (values.php line 23)
    • specified TABLE language_code to be utf8_general_ci to be accent/case insensitive for searching (language_code.php line 27)
    • specified for client browser to request MYSQL to receive/send search in utf8_general_ci for accent/case insensitive searching (values.php line 24)
  • Works under:

    • Appache 2.2.11
    • MySQL version: 5.1.30 (K) and 5.0.32 (H)
    • PHP version: 5.2.8 (K) And 5.2.6 (H)
    • WordPress Version: 2.7.1
    • Language_Code Plugin version 0.1.2 Beta
    • Database version: 1.0

0.1.1:

  • General working plug-in but some language's ISO codes would not show up when typed in. e.g. typing in 'gel' did not bring up 'Kag-Fer-Jiir-Koor-Ror-Us-Zuksun' this was a big bug.

0.0.1:

  • Import ISO 639-3 to WP_ table Creation

Requires: 2.7 or higher
Compatible up to: 2.9.2
Last Updated: 2010-1-1
Downloads: 1,228

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0