WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

K2 Style Switcher

This WordPress plugin allows site visitors to change the active style in the K2 theme.

1.1.3

  • Cleaned up plugin header and readme as part of take over from original plugin author.

1.1.2

  • Added languages folder for l10n files
  • Added German translation (de_DE), many thanks to Julian Manzel
  • Confirmed compatibility against WordPress 2.8.5

1.1.1

1.1.0

  • Encapsulated plugin functionality in a class
  • Consolidated plugin options into an array stored in a single option
  • Cleaned up code to match WordPress Coding Standards
  • Re-wrote admin panel code to use the new options mechanism introduced in WordPress 2.7
  • Made all plugin messages translatable
  • Added footer message to plugin admin panel stating the name of the plugin, the current version and the author's name
  • Re-wrote plugin activation hook to attempt to pull in existing options from current and previous versions of the plugin as well as removing redundant options
  • Added call to load the plugin l10n / i18n text domain
  • Removed plugin deactivation code to stop configuration options being removed when plugin is deactivated
  • Added uninstall script to ensure that configuration options are removed when plugin is deleted
  • Added plugin widget in a class based on the WP_Widget class introduced in WordPress 2.8
  • Added option to hide specific elements of WordPress & K2 standard footers
  • Prevented styles that are always selected from being added to the list of switchable styles
  • Took out custom WPMU checks, detection of K2 styles directory and URL is now based on K2 options
  • Added a message to the K2 options page explaining how styles are layered
  • Added code to make sure that the plugin is not loaded if K2 is not active

1.0.0

  • Initial version of plugin originally written by Kimya Hasira
  • Added WPMU compatibility

Requires: 2.8 or higher
Compatible up to: 2.9.2
Last Updated: 2010-6-15
Downloads: 3,536

Ratings

4 stars
4 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
0,2,0
0,1,0