WordPress.org

Ready to get started?Download WordPress

Plugin Directory

JSL3 Facebook Wall Feed

Displays your Facebook wall as a widget or through shortcode on a post or page.

Where can I find support for this plugin?

You can find support on the JSL3 Facebook Wall Feed page. Just add a comment and I will do my best to help you.

How do I use shortcode to add the Facebook Wall Feed to a post or page?

Switch to Text view and add the following:

[jsl3_fwf]

To limit the number of posts displayed add the 'limit' attribute:

[jsl3_fwf limit="1"]

To specify a specific feed to display add the 'fb_id' attribute and enter the feed's Facebook ID:

[jsl3_fwf fb_id="1405307559"]

If you do not enter a Facebook ID in the shortcode, the plugin will use the Facebook ID entered on the settings page for the plugin.

Can I translate the plugin?

I would be happy if you translated the plugin. You can use the 'default.po' file found in the 'wp-content/plugins/jsl3-facebook-wall-feed/languages' directory. Use Poedit to translate the plugin into your language and then save the PO file using the text domain ('jsl3-fwf'), language code and country code as the name. For example, if you translate the plugin into German, you should save the file as 'jsl3-fwf-de_DE.po'. Finally, place the translated PO file and its corresponding MO file in the 'wp-content/plugins/jsl3-facebook-wall-feed/languages' directory.

Let me know the URL of the site with the translated plugin by posting a comment on the JSL3 Facebook Wall Feed page.

How do I get rid of the 'Facebook Status' box?

To remove the 'Facebook Status' box add the following to the bottom of the style sheet on the settings page for the plugin:

/* Remove Facebook Status */
#facebook_status_box h2
{
    display: none;
}

How can I adjust the width of the Facebook Wall Feed?

To adjust the width of the Facebook Wall Feed add the following to the bottom of the style sheet on the settings page for the plugin:

/* Adjust width */
#facebook_status_box
{
    width: 225px;
}

Change the number in front of "px" to one that fits for you.

How do I adjust the height of the Facebook Wall Feed?

To adjust the height of the Facebook Wall Feed add the following to the bottom of the style sheet on the settings page for the plugin:

/* Adjust height */
#facebook_status_box
{
    height: 500px;
}
#facebook_status_box #facebook_canvas
{
    height: 460px;
}

Change the numbers in front of "px" to ones that fits for you. Try to keep the height in #facebook_status_box about 40px greater than the height in #facebook_canvas if you are keeping the 'Facebook Status' box at the top of the feed.

Why is there so much space at the bottom of my page where the plugin is located?

To remove the space at the bottom of your page add the following to the bottom of the style sheet on the settings page for the plugin:

/* Remove extra space */
#facebook_status_box #facebook_canvas .fb_post .fb_commLink .fb_likes .tooltip
{
    position: static !important;
    padding: 0 0 0 18px !important;
    opacity: 1 !important;
    filter: alpha(opacity=1) !important;
}

Why do comments look so bad?

To fix the formatting of the comments, add the following to the bottom of the style sheet on the settings page for the plugin:

/* Format comments */
#facebook_status_box .fb_msg p.fb_story
{
    font-size: 10px;
    color: #999999;
}
#facebook_status_box .fb_post .fb_comments
{
    background-color: #EDEFF4;
    font-size: 11px;
    border-bottom: 1px solid #e6e6fa;
    overflow: hidden;
    padding: 7px;
    margin: 0;
}
#facebook_status_box .fb_post .fb_comments p
{
    font-size: 11px;
    margin: 0;
    padding: 0;
    float: left;
}
#facebook_status_box .fb_post .fb_comments a
{
    color: #0A7A98;
    text-decoration: none;
}
#facebook_status_box .fb_post .fp_photo_content
{
    width: 85%
}

Why is the like icon missing from comments?

To add the like icon to comments, add the following to the bottom of the style sheet on the settings page for the plugin:

#facebook_status_box .fb_post .fb_comments .fb_comment_likes
{
    background-image: url("https://fbstatic-a.akamaihd.net/rsrc.php/v2/y-/r/tbhIfdAHjXE.png");
    background-repeat: no-repeat;
    background-position: 0 -60px;
    height: 14px;
    padding-left: 18px;
    margin-left: 5px;
}

Why is my token set to expire in less than 24 hours?

I am not sure why Facebook will give some users a short-lived token. Facebook will only allow you to attempt to renew your token once per 24 hours. Try waiting 24 hours from the last time you clicked "Save Changes" on the settings page for the plugin, then try again. If you do not get a token that lasts about 60 days, then you may want to try creating a new Facebook App for the plugin.

What does the error “OAuthException: Error validating access token: Session has expired at unix time [UNIX TIME]. The current unix time is [UNIX TIME]” mean?

It means your access token has expired. Go to the settings page for the plugin and click "Save Changes" to renew your token.

What does the error "OAuthException: Error validating access token: The session has been invalidated because the user has changed the password" mean?

It usually means you changed your Facebook password recently. Go to the settings page for the plugin and click "Save Changes" to validate your session.

What does the error "OAuthException: An access token is required to request this resource" mean?

It usually means you do not have an access token. Check that your App ID and App Secret are correct. Then click "Save Changes" on the settings page for the plugin.

What does the error "Exception: No node specified" mean?

It usually means you have not set your Facebook ID. Check that you have entered your Facebook ID on the settings page for the plugin. Then click "Save Changes" on the settings page for the plugin.

What does the error "Exception: SETTINGS: Unrecognized pref_type 0 for NullProfileSettings pref name default_non_connection_tab" mean?

It usually means are using an incorrect Facebook ID. Check that your Facebook ID is correct. Then click "Save Changes" on the settings page for the plugin.

What does "An error occurred with [Your App Name]. Please try again later" mean?

This is a Facebook error and may also include the following message:

API Error Code: 191 API Error Description: The specified URL is not owned by the application Error Message: Invalid redirect_uri: Given URL is not allowed by the Application configuration.

This error means that the App Domain and Site URL for your Facebook App do not match the domain of the website where you are using the plugin. Go to https://developers.facebook.com/apps and click "Edit Settings". Under "Basic Info", change your "App Domain" to match the domain of the website where the plugin is located. In the "Select how your app integrates with Facebook" section, under "Website with Facebook Login", change your "Site URL" to match the URL of the website where the plugin is located. Do not use "www." in your App Domain or Site URL.

Why is my feed blank?

First, a blank feed usually indicates an invalid Facebook ID. If you do not know your Facebook ID, then go to https://developers.facebook.com/tools/explorer. Click "Get Access Token". You may be prompted to log in. If you are prompted to "Select permissions", click "Get Access Token". In the text box next to the "Submit" button, enter the "Facebook Username" used in your Facebook URL (for example, my Facebook URL is https://www.facebook.com/takanudo so my Facebook Username is takanudo) followed by "?fields=id". Click Submit. Your Facebook ID will be in the results.

Second, The limit property tells Facebook how many posts to return. Some of those posts could be filtered out depending on how you have configured the plugin. For example, if you set the limit to one, the post returned may be filtered out if you have "Only show posts made by this Facebook ID" checked or "Show all status messages" unchecked or "Privacy" set to "Show only wall posts labeled public". The thoroughness option forces the plugin to keep making requests to Facebook until the limit number has been reached, but it will slow down the plugin dramatically.

Requires: 3.2.1 or higher
Compatible up to: 3.8.3
Last Updated: 2013-12-16
Downloads: 75,494

Ratings

4 stars
4.7 out of 5 stars

Support

1 of 2 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
100,2,2
0,1,0 100,1,1
100,2,2
100,1,1
100,2,2 100,1,1
100,1,1
100,1,1
0,1,0