WordPress.org

Ready to get started?Download WordPress

Plugin Directory

IE6 Upgrade Option

Generates an optional IE6 upgrade message as a plugin with output only for MSIE browsers

Plugin URL

http://www.doc4design.com/plugins/ie6-upgrade/

IE6 Upgrade Option utilizes the 25K script created by Free the Foxes: http://www.freethefoxes.com/ as a WordPress plugin. Originally this plugin utilized a smaller 7K script but it's limits had been met in terms of language support, ease-of-use and options for using the warning messages on browsers other than IE6 (refer to the ie6-upgrade-option.php file for instructions on multiple browser usage).

The warning message is displayed using a Lightbox effect that hovers over the page content. The idea is to display a warning message, simply and politely, informing the user that their browser is out of date while providing links to download newer, more optimal browser choices. Optional browser links included are: IE9, Firefox, Opera, Safari, and Chrome. While this plugin was originally intended for use with IE6 it has now been expanded, due to popular demand, to include a warning message capable of being displayed in any browser. Don't like Firefox? Simply adjust the FTF rating and ask your users to use IE8. This is not limited to a a single browser either, feel free to use the multi-browser version to display the warning in IE6, IE7 and Chrome simultaneously as a example.

The web page will remain visible through the transparent Lightbox and the user is given the option of closing the window, agreeing that their experience may be severely degraded or downloading a new browser. The javascript then installs a cookie preventing the window from appearing again. The script is loaded in the site footer in two ways: selectively (as in the case of the basic setup) or permanent (if desiring to use this for browsers other than IE6).

To change the text to reflect the language of your choice simply open the "lang" folder and create your own .json file to replace the default message, then be sure to add your new language code to the ie6-upgrade-option.php file. Current translations include: English, French, German, Spanish, Hungarian, Swedish, Brazilian Portuguese, Dutch and Norwegian Bokmâl.

Requires: 2.8 or higher
Compatible up to: 3.4.2
Last Updated: 2012-12-5
Downloads: 14,670

Ratings

4 stars
4.2 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

67,3,2
100,2,2
100,1,1 100,1,1
100,1,1 50,2,1 100,2,2
100,1,1
100,1,1
100,1,1
100,1,1 100,1,1
100,2,2 100,1,1
100,2,2
100,1,1 0,1,0
40,5,2
100,1,1
0,1,0
50,2,1
0,2,0