WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Hyper Cache Extended

Hyper Cache Extended is flexible and easy to configure cache system for WordPress. It's aim is to work on any installation.

Hyper Cache Extended is a new cache system for WordPress, specifically written for people which have their blogs on low resources hosting provider (cpu and mysql). It works even with hosting based on Microsoft IIS (just tuning the configuration). It has three invalidation method: all the cache, single post based and nothing but with control on home and archive pages invalidation. Hyper Cache Extended is based on original wordpress plugin "Hyper Cache" wich is writen by Satollo (http://wordpress.org/extend/plugins/hyper-cache)

It has not yet tested for multisite configuration (WordPress 3.0 feature).

Some features:

  • compatible with the plugin wp-pda which enables a blog to be accessible from mobile devices
  • manages (both) plain and gzip compressed pages
  • autoclean system to reduce the disk usage
  • 404 caching
  • redirects caching
  • easy to configure
  • Global Translator compatibility
  • Last Modified http header compatibility with 304 responses
  • compressed storage to reduce the disk space usage
  • agents, urls and cookies based rejection configurable
  • easy to integrated with other plugins
  • option to move cache to other partition/disk
  • only serve cached pages when web server average load is above a certain number

More can be read on the official plugin page and write me if you have issues to lazarov@mail.bg

Contribute to project: http://github.com/mlazarov/Hyper-Cache-Extended

Thanks to:

  • Satollo which is the creator of Hyper Cache
  • Amaury Balmer for internationalization and other modifications
  • Frank Luef for german translation
  • HypeScience, Martin Steldinger, Giorgio Guglielmino for test and bugs submissions
  • Ishtiaq to ask me about compatibility with wp-pda
  • Gene Steinberg to ask for an autoclean system
  • Marcis Gasun (fatcow.com) for Bielorussian translation
  • many others I don't remember

Requires: 2.5 or higher
Compatible up to: 3.5.0
Last Updated: 2014-5-30
Downloads: 40,258

Ratings

4 stars
4.5 out of 5 stars

Support

0 of 6 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1
100,1,1
100,1,1
100,1,1
100,1,1
100,2,2 100,3,3 100,1,1 75,4,3 100,2,2 100,1,1
100,1,1
100,1,1 100,2,2
100,2,2
50,4,2
100,2,2 100,2,2
100,1,1 100,2,2 100,7,7 100,5,5 100,1,1
100,3,3 100,1,1 100,1,1
100,3,3 50,6,3 75,4,3 100,5,5 0,1,0
100,6,6
0,1,0
100,5,5
100,1,1
100,2,2
50,2,1
100,1,1 100,1,1