WordPress.org

Ready to get started?Download WordPress

Plugin Directory

HTTPS Redirection

The plugin allows an automatic redirection to the "HTTPS" version/URL of the site. Make your site SSL compatible.

After you install SSL certificate on your site, you want to use the "HTTPS" URL of your webpages.

You want to force search engines to index your HTTPS version of the webpage(s).

This plugin will help you automatically setup a redirection to the https version of an URL when anyone tries to access the non-https version.

Lets say for example, you want to use HTTPS URL for the following page on your site:

example.com/checkout

This plugin will enforce that so if anyone uses an URL like the following in the browser's address bar: http://www.example.com/checkout

It will automatically redirect to the following HTTPS version of the page: https://www.example.com/checkout

So you are always forcing the visitor to view the HTTPS version of the page or site in question.

You can force your entire domain to be auto redirected to the HTTPS URL or selectively choose a few pages to be re-directed.

Force Load Static Files Using HTTPS

If you started using SSL from day 1 of your site then all your static files are already embedded using HTTPS URL. You have no issue there.

However, if you have an existing website where you have a lot of static files that are embedded in your posts and pages using NON-HTTPS URL then you will need to change those. Otherwise, the browser will show an SSL warning to your visitors.

This plugin has an option that will allow you to force load those static files using HTTPS URL dynamically.

This will help you make the webpage fully compatible with SSL.

Features

  • Actions: Do an auto redirect for the whole domain. So every URL will be redirected to the HTTPS version automatically.
  • Actions: Do an auto redirect for a few pages. The user can enter the URLs that will be auto redirected to the HTTPS version.
  • Force load static files (images, js, css etc) using a HTTPS URL.

Requires: 3.5 or higher
Compatible up to: 3.9.2
Last Updated: 2014-8-17
Downloads: 638

Ratings

3 stars
3.7 out of 5 stars

Support

1 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0 100,1,1
100,1,1