WordPress.org

Ready to get started?Download WordPress

Plugin Directory

HTML5 Placeholder Polyfill

Mimics HTML5 placeholder behavior in browsers that don't natively support it.

The HTML5 Placeholder Plugin simulates placeholder functionality for inputs and textareas, which is particularly handy in browsers that still need some work.

A MIGHTYminnow plugin.

Features

  • No setup necessary, works immediately after installing
  • Super lightweight, less than 3kb minified jQuery
  • Automatically detects for placeholder support - no need for extra feature detection like Modernizr
  • Based on Mathias Bynens' widely popular and well tested polyfill - thanks Mathias!

How to use

This plugin creates and uses a placeholder() jQuery function, and invokes it for inputs and textareas. This happens automatically as soon as you install it. If for some crazy reason you would like to invoke it on other elements aside from inputs and textareas, you can do so with you own jQuery, like so:

jQuery('yourElement').placeholder()

Requires: 3.0 or higher
Compatible up to: 4.0
Last Updated: 2014-7-14
Downloads: 933

Ratings

5 stars
5 out of 5 stars

Support

1 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.