WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Hosting Monitor

Track how much disk and database space WordPress is using.

Plugin Requirements

This Plugin only works completely on Linux/Apache servers. Windows IIS servers don't work right. To see the pie charts on the Settings page, your server needs to have GD 2.0.1 or later installed and have JPG Support enabled. Without this the plugin will not fail, but you won't see a pie chart.

Does this Plugin run on Windows web servers?

Not entirely. It works on Windows Apache, but has errors on Windows IIS.

I've noticed my Dashboard is slow. What gives?

The used disk space is calculated when the Dashboard is loaded. It can be slow because the server counts every file, every time. On slow servers this can take some time. We agree that it's annoying and plan to fix it.

To prevent this, close the dahsboard window using the little arrow in the top-right corner. Alternatively, click on Screen Options and disable the widget.

Are you going to fix {bug X}?

Yes, as quickly as we can. The problems in version 0.5 and some we inherited from a previous plugin should be fixable. We can probably make this work correctly on Windows servers. And, we should be able to cache the disk space stats so the dashboard is not so slow.

There will be additional features added in future versions too: The 1st one planned is better alerts for when you're using too much disk-space (including an optional email alert). Second is adding bandwidth monitoring. Then we'll move on to adding tools for tracking & alerting if your server is down.

Where did this come from, and will you keep updating it?

Hosting Monitor is produced by: http://www.AliveMediaDev.com, and developed by: http://www.EtchSoftware.com. It is built with code from Disk Space Pie Chart by Jay Versluis and the Pie Chart Script by Rasmus Peters.

This plugin is installed on many of our customer sites. We plan to keep it updated and to add new features as often as time allows. It is more than just a hobby, since it must be updated for new versions of WordPress.

Requires: 3.0 or higher
Compatible up to: 3.9.1
Last Updated: 2014-4-24
Downloads: 4,338

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1
100,1,1 100,4,4 100,2,2 100,2,2
100,2,2
100,2,2 100,1,1
100,2,2
100,1,1
100,2,2
100,1,1
100,1,1 100,1,1
50,2,1 100,1,1 100,3,3
100,2,2
100,1,1
100,1,1
100,1,1
100,2,2
50,2,1
100,1,1
100,3,3
100,1,1