WordPress.org

Ready to get started?Download WordPress

Plugin Directory

HeadJS Plus

A plugin to load your Javascript files via Head JS.

This plugin reformats your page to utilize Head JS in your WordPress site.

Based on the initial plugin by Durin

It strips out all your old javascript declarations and puts them into head.js calls so that they are loaded in parallel (see the Head JS website for more details).

For example, this:

<script type='text/javascript' src='http://yoururl.com/wp-includes/js/prototype.js?ver=1.6.1'></script> 
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.4/jquery.min.js?ver=3.0.4'></script> 
<script type='text/javascript' src='http://yoururl.com/wp-includes/js/scriptaculous/wp-scriptaculous.js?ver=1.8.3'></script> 
<script type='text/javascript' src='http://yoururl.com/wp-includes/js/scriptaculous/builder.js?ver=1.8.3'></script> 
<script type='text/javascript' src='http://yoururl.com/wp-includes/js/scriptaculous/effects.js?ver=1.8.3'></script> 
<script type='text/javascript' src='http://yoururl.com/wp-includes/js/scriptaculous/dragdrop.js?ver=1.8.3'></script> 
<script type='text/javascript' src='http://yoururl.com/wp-includes/js/scriptaculous/slider.js?ver=1.8.3'></script> 
<script type='text/javascript' src='http://yoururl.com/wp-includes/js/scriptaculous/controls.js?ver=1.8.3'></script>

Becomes:

<script type="text/javascript" src="http://yoururl.com/wp-content/plugins/headjs-loader/head.min.js"></script> 
<script> 
head.js("http://yoururl.com/wp-includes/js/prototype.js?ver=1.6.1")
    .js("http://ajax.googleapis.com/ajax/libs/jquery/1.4/jquery.min.js?ver=3.0.4")
    .js("http://yoururl.com/wp-includes/js/scriptaculous/wp-scriptaculous.js?ver=1.8.3")
    .js("http://yoururl.com/wp-includes/js/scriptaculous/builder.js?ver=1.8.3")
    .js("http://yoururl.com/wp-includes/js/scriptaculous/effects.js?ver=1.8.3")
    .js("http://yoururl.com/wp-includes/js/scriptaculous/dragdrop.js?ver=1.8.3")
    .js("http://yoururl.com/wp-includes/js/scriptaculous/slider.js?ver=1.8.3")
    .js("http://yoururl.com/wp-includes/js/scriptaculous/controls.js?ver=1.8.3");
</script>

Requires: 3.0 or higher
Compatible up to: 3.9.2
Last Updated: 2014-7-20
Downloads: 1,903

Ratings

5 stars
5 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1 100,1,1