WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Gravity Forms Placeholder Add-On

This plugin adds Placeholder support to gravity forms

NOTE The plugin is based off of the placeholder support add-on initially developed by neojp and can be found at the link below. The main difference being that we added support for drop-down fields. https://wordpress.org/plugins/gravity-forms-placeholders/

This plugin gives support for placeholders to the Gravity Forms WordPress Plugin.

In order to use the plugin you need only add the class of \"gf-add-placeholder\" to any of the fields you wish to have a placeholder on.

The plugin will take the text of the label and then hide said label and apply the text from the label to the placeholder attribute.

If you would like to to use this on your entire form then you need only add the \"gf-add-placeholder\" class to the form itself and then it will be applied to all the form elements.

DROPDOWN FIELDS

As im sure you know, the select field in HTML does not have a native placeholder attribute. Now you can do what some do and just add an option that says \"please select\" but that is not (in my opinion) the best way.

This plugin does the following to give a placeholder LIKE support to the select fields

It takes and hides the label just like it does with the other fields but then it takes the text from that label and prepends an option to the select field that contains the text from the label as it\'s value and it also adds a selected and disabled attribute to the option. Ensuring that it is selected and also ensuring that once a user clicks into the field that they wont be able to select and submit with that option.

In the future i fully intend on adding features that will allow the hiding of labels to be optional and the feature for you to be able to manually set your placeholder text as opposed to it just pulling in the label text.

The plugin requires Javascript and Jquery to function and is tested up to WordPress version 3.8.1 and Gravity Forms Version 1.8

ENJOY! and happy coding :)

Requires: 3.6 or higher
Compatible up to: 3.9.2
Last Updated: 2014-5-5
Downloads: 4,280

Ratings

4 stars
4.1 out of 5 stars

Support

0 of 5 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

1 person says it works.
0 people say it's broken.

100,1,1 100,2,2
100,1,1
100,3,3
100,1,1