WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Gravity Forms Highrise CRM

Send your Gravity Forms submissions to Highrise

Send your Gravity Forms submissions to Highrise

Requires: 3.3 or higher
Compatible up to: 3.9.1
Last Updated: 2014-6-4
Downloads: 827

Ratings

5 stars
5 out of 5 stars

Support

1 of 1 support threads in the last two months have been resolved.

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.