WordPress.org

Ready to get started?Download WordPress

Plugin Directory

Gpx2Chart

A plugin that generates nice charts from GPX-files. It put's all information about heartrate, cadence, elevation and speed into one chart.

0.4.0

  • updated flot-library to more recent version
  • added basic support for displaying pace

0.3.3

  • removed bundle with Highcharts API. Library is not compatible with GPL. So if you need to use Highcharts please download it yourself

0.3.2

  • Modified GPX-Parser to be a little bit more compatible for different type of GPX-files

0.3.1

  • Added function to modify profiles and styles on option page
  • Added a function to clone profiles and styles on option page

0.3.0

  • complete code rewrite
  • layout is now located in a profile-file
  • a lot of configuration can be done in the brand new plugins-configuration page to adjust the look and feel
  • tested on Chrome 17.0.963.83, Firefox 9.0.1, IE 9, IE9 (IE8+IE7 compatible-mode)

0.2.1

  • commented out some code, so the tooltips look a bit more friendly
  • Fixed depency injection for excanvas and highcharts
  • debug-mode is disabled now for production-usage
  • Use minified versions of the js-files now
  • Put strftime-function to js/helpers
  • Fixed Tooltip for IE

0.2.0

  • Change to FLOT-API as default rendering engine instead of Highcharts.
  • GPX2Chart is still shipped with both rendering engines (Flot and Highcharts)
  • Highcharts is still supported if you add render="highchart" to the option-tags. This will most likely change in future and flot will stay the only rendering engine that get's further development.

0.1.5

  • improved error-handling if href is not defined
  • improved error-handling if file could not be opened
  • additional parameters are now available (metadata, display, width, debug)
  • removed the need for the $-object. I now use jQuery directly
  • dashstyle and seriestype are now in variables
  • Introduced CSS-Classes gpx2chart, gpx2chartchart, gpx2chartmeta, gpx2chartdebug. They are not filled with life yet.

0.1.4

  • Seems like some interfaces won't work on host-europe. Interfaces are removed now

0.1.3

  • Fixed problem when using the plugins_url() function. I couldn't see this error previously, cause I did not use the automatic installation :)

0.1.2

  • Rename from ww_gpx_info to gpx2chart

0.1

  • Initial version of this plugin

Requires: 3.1.2 or higher
Compatible up to: 3.3.2
Last Updated: 2012-10-6
Downloads: 1,017

Ratings

4 stars
4.3 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

0,1,0 100,1,1 100,1,1
100,1,1 100,1,1 100,1,1 100,2,2
100,2,2
100,1,1 0,1,0 100,1,1 100,2,2 100,1,1 100,1,1
100,2,2