WordPress.org

Ready to get started?Download WordPress

Plugin Directory

!This plugin hasn't been updated in over 2 years. It may no longer be maintained or supported and may have compatibility issues when used with more recent versions of WordPress.

Google Syntax Highlighter for WordPress

This plugin makes using the Google Syntax highlighter by Alex Gorbatchev to highlight code snippets within WordPress simple.

  1. Extract plugin into /wp-content/plugins directory.
  2. Activate the plugin.
  3. Specify your code snippets in your blog post using the Usage Directions provided by the Google Syntax highlighter.

Here is an example to produce ruby syntax highlighting once the plugin is activated:

<pre name="code" class"ruby">
def my_ruby_snippet
  blog_post.should(be_highlighted)
end
</pre>

Requires: 2.0.0 or higher
Compatible up to: 2.2.2
Last Updated: 2007-8-14
Downloads: 42,647

Ratings

4 stars
4.3 out of 5 stars

Support

Got something to say? Need help?

Compatibility

+
=
Not enough data

0 people say it works.
0 people say it's broken.

100,1,1
80,5,4
60,5,3
50,2,1
33,6,2
100,1,1
0,1,0
100,3,3
100,2,2
0,1,0
100,1,1
0,1,0
100,1,1